summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/qd/qd-2.3.13.ebuild')
-rw-r--r--sci-libs/qd/qd-2.3.13.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sci-libs/qd/qd-2.3.13.ebuild b/sci-libs/qd/qd-2.3.13.ebuild
index d4124ee9b288..e1089fc5e736 100644
--- a/sci-libs/qd/qd-2.3.13.ebuild
+++ b/sci-libs/qd/qd-2.3.13.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.13.ebuild,v 1.1 2012/04/18 23:20:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.13.ebuild,v 1.2 2012/06/25 16:53:25 jlec Exp $
EAPI=4
-inherit eutils fortran-2
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils fortran-2
DESCRIPTION="Quad-double and double-double float arithmetics"
HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
@@ -22,16 +24,20 @@ pkg_setup() {
use fortran && fortran-2_pkg_setup
}
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-shared
$(use_enable fortran enable_fortran)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
+
use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
dosym qd_real.h /usr/include/qd/qd.h
dosym dd_real.h /usr/include/qd/dd.h