summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch35
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch21
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch
new file mode 100644
index 000000000000..2061d16f71ea
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch
@@ -0,0 +1,35 @@
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
+ #endif /* _CACHE_COMMON_H */
+
+--- a/testpar/t_span_tree.c
++++ b/testpar/t_span_tree.c
+@@ -37,6 +37,9 @@
+ #include "hdf5.h"
+ #include "H5private.h"
+ #include "testphdf5.h"
++#define H5S_PACKAGE
++#define H5S_TESTING
++#include "H5Spkg.h"
+
+
+ static void coll_write_test(int chunk_factor);
+--- a/configure.ac
++++ b/configure.ac
+@@ -1504,6 +1504,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ ## _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
diff --git a/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch b/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch
new file mode 100644
index 000000000000..82bc5d8b120a
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch
@@ -0,0 +1,21 @@
+Prevent build system with messing up LD_LIBRARY_PATH
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5Tinit.c: H5detect$(EXEEXT)
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
+@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)