summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild')
-rw-r--r--sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild b/sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild
new file mode 100644
index 000000000000..7b6e076269b7
--- /dev/null
+++ b/sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-4.3.7284.3916.ebuild,v 1.1 2010/03/16 09:14:19 caster Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+SRC_URI="http://dl.google.com/earth/client/ge4/release_4_3/googleearth-linux-plus-4.3.7284.3916.bin
+ -> GoogleEarthLinux-${PV}.bin"
+
+LICENSE="googleearth MIT SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE=""
+
+RDEPEND="x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrender )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ <x11-drivers/ati-drivers-8.28.8 ) )
+ media-fonts/ttf-bitstream-vera"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_makeself
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" postinstall.sh
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml
+ domenu Google-${PN}.desktop
+ doicon ${PN}-icon.png
+ dodoc README.linux
+
+ cd bin
+ tar xf "${WORKDIR}"/${PN}-linux-x86.tar
+ exeinto /opt/${PN}
+ doexe *
+
+ cd "${D}"/opt/${PN}
+ tar xf "${WORKDIR}"/${PN}-data.tar
+
+ cd "${D}"
+ # mime magic for gnome by Ed Catmur in bug 141371
+ epatch "${FILESDIR}"/mime-magic.patch
+
+ # make sure we install with correct permissions
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}