summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-4.6.6.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.6.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/gromacs-4.6.6.ebuild b/sci-chemistry/gromacs/gromacs-4.6.6.ebuild
index 51f1411701b7..65e796123a07 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.6.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6.6.ebuild,v 1.1 2014/07/07 17:51:39 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6.6.ebuild,v 1.2 2015/01/31 20:23:56 ottxor Exp $
EAPI=5
@@ -34,7 +34,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
fi
-ACCE_IUSE="sse2 sse4_1 avx128fma avx256"
+ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx"
DESCRIPTION="The ultimate molecular dynamics simulation package"
HOMEPAGE="http://www.gromacs.org/"
@@ -131,10 +131,10 @@ src_configure() {
#go from slowest to fastest acceleration
local acce="None"
- use sse2 && acce="SSE2"
- use sse4_1 && acce="SSE4.1"
- use avx128fma && acce="AVX_128_FMA"
- use avx256 && acce="AVX_256"
+ use cpu_flags_x86_sse2 && acce="SSE2"
+ use cpu_flags_x86_sse4_1 && acce="SSE4.1"
+ use cpu_flags_x86_fma4 && acce="AVX_128_FMA"
+ use cpu_flags_x86_avx && acce="AVX_256"
#to create man pages, build tree binaries are executed (bug #398437)
[[ ${CHOST} = *-darwin* ]] && \