summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/externaleditor/externaleditor-0.5.ebuild')
-rw-r--r--net-zope/externaleditor/externaleditor-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-zope/externaleditor/externaleditor-0.5.ebuild b/net-zope/externaleditor/externaleditor-0.5.ebuild
new file mode 100644
index 000000000000..10b508be91ba
--- /dev/null
+++ b/net-zope/externaleditor/externaleditor-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public Form License v2
+# $Header $
+
+inherit zproduct
+
+DESCRIPTION="Allows you to use your favorite editor(s) from ZMI."
+HOMEPAGE="http://www.zope.org/Members/Caseman/ExternalEditor/"
+SRC_URI="${HOMEPAGE}/ExternalEditor-${PV}.tgz
+ ${HOMEPAGE}/zopeedit-${PV}-src.tgz"
+LICENSE="ZPL"
+KEYWORDS="~x86 ~ppc"
+
+ZPROD_LIST="ExternalEditor"
+
+src_install()
+{
+ dobin zopeedit.py
+ rm -f zopeedit.py
+ zproduct_src_install all
+}
+
+pkg_postinst()
+{
+ zproduct_pkg_postinst
+ ewarn
+ ewarn "To use the External Editor Zope Product you will need to manually"
+ ewarn "configure the helper application(/usr/bin/zopeedit.py) for your"
+ ewarn "browser. Read the documention for ExternalEditor."
+}