summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/liferea/files/liferea-1.6.6b-libnotify-0.7.patch')
-rw-r--r--net-news/liferea/files/liferea-1.6.6b-libnotify-0.7.patch70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-news/liferea/files/liferea-1.6.6b-libnotify-0.7.patch b/net-news/liferea/files/liferea-1.6.6b-libnotify-0.7.patch
deleted file mode 100644
index 2cce165ec29d..000000000000
--- a/net-news/liferea/files/liferea-1.6.6b-libnotify-0.7.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -NrU5 liferea-1.6.6b.original/configure.ac liferea-1.6.6b/configure.ac
---- liferea-1.6.6b.original/configure.ac 2011-06-22 09:16:24.000000000 -0600
-+++ liferea-1.6.6b/configure.ac 2011-08-08 09:21:49.000000000 -0600
-@@ -75,11 +75,11 @@
- dnl *********
- dnl libnotify
- dnl *********
-
- if test "x$enable_libnotify" = "xyes"; then
-- PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= 0.3.2, libnotify <= 0.5],enable_libnotify=yes,enable_libnotify=no)
-+ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= 0.3.2],enable_libnotify=yes,enable_libnotify=no)
- AC_SUBST(LIBNOTIFY_CFLAGS)
- AC_SUBST(LIBNOTIFY_LIBS)
- else
- enable_libnotify=no
- fi
-diff -NrU5 liferea-1.6.6b.original/src/notification/libnotify.c liferea-1.6.6b/src/notification/libnotify.c
---- liferea-1.6.6b.original/src/notification/libnotify.c 2011-06-22 07:25:40.000000000 -0600
-+++ liferea-1.6.6b/src/notification/libnotify.c 2011-08-08 09:21:11.000000000 -0600
-@@ -26,10 +26,14 @@
- #include <gtk/gtk.h>
- #include <glib.h>
-
- #include <libnotify/notify.h>
-
-+#ifndef NOTIFY_CHECK_VERSION
-+#define NOTIFY_CHECK_VERSION(x,y,z) 0
-+#endif
-+
- #include "common.h"
- #include "conf.h"
- #include "debug.h"
- #include "node.h"
- #include "item.h"
-@@ -148,11 +152,16 @@
-
- if(node_p) {
- // notify_notification_update ( n, node_get_title(node_p), labelText_now_p, NULL);
- // notify_notification_clear_actions(n);
-
-- n = notify_notification_new (node_get_title(node_p), labelText_now_p, NULL, NULL);
-+ n = notify_notification_new (node_get_title(node_p), labelText_now_p, NULL
-+#if NOTIFY_CHECK_VERSION (0, 7, 0)
-+ );
-+#else
-+ , NULL);
-+#endif
-
- notify_notification_set_icon_from_pixbuf (n,node_get_icon(node_p));
-
- notify_notification_set_category (n, "feed");
-
-@@ -242,11 +251,16 @@
- if (item_count == 0)
- return;
-
- labelSummary_p = g_strdup_printf (ngettext ("%s has %d new / updated headline\n", "%s has %d new / updated headlines\n", item_count),
- node_get_title (node), item_count);
-- n = notify_notification_new ( _("Feed Update"), labelSummary_p, NULL, NULL);
-+ n = notify_notification_new ( _("Feed Update"), labelSummary_p, NULL
-+#if NOTIFY_CHECK_VERSION (0, 7, 0)
-+ );
-+#else
-+ , NULL);
-+#endif
- g_free(labelSummary_p);
-
- notify_notification_set_icon_from_pixbuf (n, node_get_icon (node));
- notify_notification_set_timeout (n, NOTIFY_EXPIRES_DEFAULT);
- if (supports_actions) {