summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/ypserv/ypserv-1.3.9-r6.ebuild')
-rw-r--r--net-nds/ypserv/ypserv-1.3.9-r6.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-nds/ypserv/ypserv-1.3.9-r6.ebuild b/net-nds/ypserv/ypserv-1.3.9-r6.ebuild
new file mode 100644
index 000000000000..a9631cc1d67f
--- /dev/null
+++ b/net-nds/ypserv/ypserv-1.3.9-r6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-1.3.9-r6.ebuild,v 1.1 2001/10/06 07:25:11 woodchip Exp $
+
+P=ypserv-1.3.9
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="NIS SERVER"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.uk.kernel.org/pub/linux/utils/net/NIS/${A}
+ ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${A}"
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypserv/index.html"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/defs.sed ypmake
+}
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--enable-tcp-wrapper"
+
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --mandir=/usr/share/man \
+ --enable-yppasswd $myconf || die
+
+ make || die
+
+ cd ${S}/ypmake
+ sed -f defs.sed Makefile.in > Makefile
+ make || die
+}
+
+src_install() {
+ local MYMAN=${D}/usr/share/man
+
+ make prefix=${D}/usr YPMAPDIR=${D}/var/yp CONFDIR=${D}/etc \
+ MAN1DIR=$MYMAN/man1 MAN5DIR=$MYMAN/man5 MAN8DIR=$MYMAN/man8 \
+ installdirs install_progs || die
+
+ exeinto /usr/sbin
+ cd ${S}/contrib ; doexe ypslave
+ cd ${S}/ypmake ; doexe ypmake
+
+ insinto /usr/lib/yp/ypmake
+ for i in aliases arrays automount config ethers group gshadow hosts \
+ netgroup netid networks passwd protocols publickey \
+ rpc services shadow ypservers
+ do
+ doins $i
+ done
+
+ insinto /var/yp
+ doins ypmake.conf.sample
+
+ newman ypmake.man ypmake.8
+ newman ypmake.conf.man ypmake.conf.5
+
+ cd ${S}
+ dodoc BUGS ChangeLog HOWTO.SuSE NEWS TODO
+
+ insinto /etc ; doins etc/ypserv.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ypserv.rc6 ypserv
+}