summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ipv6calc/ChangeLog7
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.93.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-misc/ipv6calc/ChangeLog b/net-misc/ipv6calc/ChangeLog
index 9b9bebc9192d..ce35c83df0a0 100644
--- a/net-misc/ipv6calc/ChangeLog
+++ b/net-misc/ipv6calc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ipv6calc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.48 2012/02/14 21:06:58 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ChangeLog,v 1.49 2012/03/16 09:58:13 patrick Exp $
+
+*ipv6calc-0.93.1 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +ipv6calc-0.93.1.ebuild:
+ Bump
14 Feb 2012; Brent Baude <ranger@gentoo.org> ipv6calc-0.90.0-r1.ebuild:
Marking ipv6calc-0.90.0-r1 ppc for bug 379063
diff --git a/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild b/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild
new file mode 100644
index 000000000000..abc64bec4d26
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.93.1.ebuild,v 1.1 2012/03/16 09:58:13 patrick Exp $
+
+EAPI="4"
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.7 )"
+
+src_prepare() {
+ # Tests don't work, will be fixed next release
+ echo true > ipv6calc/test_showinfo.sh || die
+ ht_fix_file configure
+}
+
+src_configure() {
+ econf $(use_enable geoip)
+}
+
+src_compile() {
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}