summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvpn/openvpn-1.3.1.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/openvpn/openvpn-1.3.1.ebuild b/net-misc/openvpn/openvpn-1.3.1.ebuild
new file mode 100644
index 000000000000..c9674a173bd0
--- /dev/null
+++ b/net-misc/openvpn/openvpn-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mike Jones <ashmodai@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.3.1.ebuild,v 1.1 2002/07/16 04:24:10 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/openvpn/${P}.tar.gz"
+HOMEPAGE="http://openvpn.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+DEPEND=">=dev-libs/lzo-1.07
+ virtual/linux-sources
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use ssl || myconf='--disable-ssl --disable-crypto'
+
+ ./autogen.sh || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING CHANGES INSTALL PORTS README
+
+}