summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gsasl/gsasl-0.2.28.ebuild')
-rw-r--r--net-misc/gsasl/gsasl-0.2.28.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/gsasl/gsasl-0.2.28.ebuild b/net-misc/gsasl/gsasl-0.2.28.ebuild
new file mode 100644
index 000000000000..8232c6a5c253
--- /dev/null
+++ b/net-misc/gsasl/gsasl-0.2.28.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-0.2.28.ebuild,v 1.1 2008/09/07 08:27:19 dertobi123 Exp $
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc gnutls idn kerberos nls"
+PROVIDE="virtual/gsasl"
+DEPEND="nls? ( >=sys-devel/gettext-0.16.1 )
+ kerberos? ( virtual/krb5 )
+ idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ --enable-client \
+ --enable-server \
+ $(use_enable kerberos gssapi) \
+ $(use_enable kerberos kerberosv5) \
+ $(use_with idn stringprep) \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README README-alpha THANKS
+ doman doc/gsasl.1
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*.c
+ fi
+}