summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r2.patch')
-rw-r--r--net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r2.patch123
1 files changed, 123 insertions, 0 deletions
diff --git a/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r2.patch b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r2.patch
new file mode 100644
index 000000000000..a5b12a4fb920
--- /dev/null
+++ b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r2.patch
@@ -0,0 +1,123 @@
+diff -Nru vmailmgr-0.96.9.orig/authenticate/Makefile.am vmailmgr-0.96.9/authenticate/Makefile.am
+--- vmailmgr-0.96.9.orig/authenticate/Makefile.am 2000-09-23 23:23:32.000000000 +0300
++++ vmailmgr-0.96.9/authenticate/Makefile.am 2005-03-05 13:25:48.178155952 +0200
+@@ -1,6 +1,6 @@
+ bin_PROGRAMS = checkvpw vauthenticate
+ authlib_PROGRAMS = authvmailmgr
+-authlibdir = ${prefix}/lib/courier-imap/libexec/authlib/
++authlibdir = ${prefix}/lib/courier-imap/authlib/
+
+ noinst_PODS = checkvpw.pod vauthenticate.pod
+ noinst_HTMLS = $(noinst_PODS:.pod=.html)
+diff -Nru vmailmgr-0.96.9.orig/authenticate/Makefile.in vmailmgr-0.96.9/authenticate/Makefile.in
+--- vmailmgr-0.96.9.orig/authenticate/Makefile.in 2000-10-01 07:33:29.000000000 +0300
++++ vmailmgr-0.96.9/authenticate/Makefile.in 2005-03-05 13:25:48.178155952 +0200
+@@ -83,7 +83,7 @@
+
+ bin_PROGRAMS = checkvpw vauthenticate
+ authlib_PROGRAMS = authvmailmgr
+-authlibdir = ${prefix}/lib/courier-imap/libexec/authlib/
++authlibdir = ${prefix}/lib/courier-imap/authlib/
+
+ noinst_PODS = checkvpw.pod vauthenticate.pod
+ noinst_HTMLS = $(noinst_PODS:.pod=.html)
+diff -Nru vmailmgr-0.96.9.orig/authenticate/authvmailmgr.cc vmailmgr-0.96.9/authenticate/authvmailmgr.cc
+--- vmailmgr-0.96.9.orig/authenticate/authvmailmgr.cc 2000-08-01 20:09:27.000000000 +0300
++++ vmailmgr-0.96.9/authenticate/authvmailmgr.cc 2005-03-05 13:25:48.179155800 +0200
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "misc/exec.h"
+ #include "authvlib.h"
+ // Courier-IMAP includes
+diff -Nru vmailmgr-0.96.9.orig/authenticate/checkvpw.cc vmailmgr-0.96.9/authenticate/checkvpw.cc
+--- vmailmgr-0.96.9.orig/authenticate/checkvpw.cc 2000-08-11 01:39:27.000000000 +0300
++++ vmailmgr-0.96.9/authenticate/checkvpw.cc 2005-03-05 13:25:48.179155800 +0200
+@@ -18,6 +18,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <stdlib.h>
+ #include "config/configrc.h"
+ #include "misc/exec.h"
+ #include "misc/stat_fns.h"
+diff -Nru vmailmgr-0.96.9.orig/authenticate/vauthenticate.cc vmailmgr-0.96.9/authenticate/vauthenticate.cc
+--- vmailmgr-0.96.9.orig/authenticate/vauthenticate.cc 2000-08-01 21:05:31.000000000 +0300
++++ vmailmgr-0.96.9/authenticate/vauthenticate.cc 2005-03-05 13:25:48.180155648 +0200
+@@ -17,6 +17,7 @@
+ #include <config.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include "authvlib.h"
+ #include "fdbuf/fdbuf.h"
+
+diff -Nru vmailmgr-0.96.9.orig/configure vmailmgr-0.96.9/configure
+--- vmailmgr-0.96.9.orig/configure 2000-10-01 07:24:23.000000000 +0300
++++ vmailmgr-0.96.9/configure 2005-03-05 13:25:48.182155344 +0200
+@@ -2682,7 +2682,7 @@
+ done
+
+
+-cgidir='${prefix}/cgi-bin'
++cgidir='/var/www/localhost/cgi-bin'
+
+
+ trap '' 1 2 15
+diff -Nru vmailmgr-0.96.9.orig/lib/cdb++/cdb++.h vmailmgr-0.96.9/lib/cdb++/cdb++.h
+--- vmailmgr-0.96.9.orig/lib/cdb++/cdb++.h 2000-04-05 22:11:45.000000000 +0300
++++ vmailmgr-0.96.9/lib/cdb++/cdb++.h 2005-03-05 13:27:26.573197632 +0200
+@@ -20,8 +20,9 @@
+ #include "mystring/mystring.h"
+ #include "cdb++/datum.h"
+ #include "fdbuf/fdbuf.h"
++#include <inttypes.h>
+
+-typedef unsigned long uint32;
++typedef uint32_t uint32;
+
+ #define CDBMAKE_HPLIST 1000
+
+diff -Nru vmailmgr-0.96.9.orig/lib/misc/exec.cc vmailmgr-0.96.9/lib/misc/exec.cc
+--- vmailmgr-0.96.9.orig/lib/misc/exec.cc 2000-08-03 19:35:09.000000000 +0300
++++ vmailmgr-0.96.9/lib/misc/exec.cc 2005-03-05 13:25:48.182155344 +0200
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
++#include <string.h>
+ #include "exec.h"
+ #include "config/configrc.h"
+
+diff -Nru vmailmgr-0.96.9.orig/lib/misc/keystrlist.cc vmailmgr-0.96.9/lib/misc/keystrlist.cc
+--- vmailmgr-0.96.9.orig/lib/misc/keystrlist.cc 2000-04-03 21:22:13.000000000 +0300
++++ vmailmgr-0.96.9/lib/misc/keystrlist.cc 2005-03-05 13:25:48.183155192 +0200
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ void keystrlist::set(const mystring& var, const mystring& val)
+diff -Nru vmailmgr-0.96.9.orig/lib/misc/strlist.cc vmailmgr-0.96.9/lib/misc/strlist.cc
+--- vmailmgr-0.96.9.orig/lib/misc/strlist.cc 2000-04-03 21:22:14.000000000 +0300
++++ vmailmgr-0.96.9/lib/misc/strlist.cc 2005-03-05 13:25:48.183155192 +0200
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ static const char* compare(const char* ptr, const char* end,
+diff -Nru vmailmgr-0.96.9.orig/lib/mystring/append.cc vmailmgr-0.96.9/lib/mystring/append.cc
+--- vmailmgr-0.96.9.orig/lib/mystring/append.cc 2000-02-13 07:16:03.000000000 +0200
++++ vmailmgr-0.96.9/lib/mystring/append.cc 2005-03-05 13:25:48.184155040 +0200
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include "mystring.h"
+ #include "trace.h"
+