summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/vacation/vacation-1.2.6.1.ebuild')
-rw-r--r--net-mail/vacation/vacation-1.2.6.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-mail/vacation/vacation-1.2.6.1.ebuild b/net-mail/vacation/vacation-1.2.6.1.ebuild
new file mode 100644
index 000000000000..c91d814212d6
--- /dev/null
+++ b/net-mail/vacation/vacation-1.2.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vacation/vacation-1.2.6.1.ebuild,v 1.1 2003/03/14 15:40:04 phosphan Exp $
+
+DESCRIPTION="automatic mail answering program"
+HOMEPAGE="http://vacation.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sourceforge/vacation/${PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/mta
+ sys-libs/gdbm"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ mv vacation.man vacation.1
+ mv Makefile Makefile.orig
+ sed < Makefile.orig -e 's: -m486::' | sed -e 's:CFLAGS.*= \(.*\):CFLAGS += \1:' > Makefile
+}
+
+src_compile () {
+ emake CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install () {
+ dobin vacation
+ dodoc AUTHORS ChangeLog README README.smrsh
+ doman vacation.1
+}