summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog9
-rw-r--r--net-fs/samba/files/digest-samba-2.2.51
-rw-r--r--net-fs/samba/files/smb.conf.example12
-rw-r--r--net-fs/samba/samba-2.2.5.ebuild312
4 files changed, 323 insertions, 11 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index a09fa248a485..2e820ac88a25 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/samba
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.9 2002/05/14 05:24:01 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.10 2002/06/23 20:56:52 woodchip Exp $
+
+*samba-2.2.5 (23 Jun 2002)
+
+ 23 Jun 2002; Donny Davies <woodchip@gentoo.org> :
+
+ Update to latest; samba-2.2.5. Please see the samba WHATSNEW.txt file
+ in /usr/doc/samba for the detailed fixes.
*samba-2.2.4-r1 (13 May 2002)
diff --git a/net-fs/samba/files/digest-samba-2.2.5 b/net-fs/samba/files/digest-samba-2.2.5
new file mode 100644
index 000000000000..8e17a3d11b74
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-2.2.5
@@ -0,0 +1 @@
+MD5 4899dfdca88d86e7809c16f23c24eecc samba-2.2.5.tar.gz 5293193
diff --git a/net-fs/samba/files/smb.conf.example b/net-fs/samba/files/smb.conf.example
index dd2ce2961c66..c41d7ed939ec 100644
--- a/net-fs/samba/files/smb.conf.example
+++ b/net-fs/samba/files/smb.conf.example
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/smb.conf.example,v 1.1 2002/05/06 19:57:08 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/smb.conf.example,v 1.2 2002/06/23 20:56:53 woodchip Exp $
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options (perhaps too
@@ -17,7 +17,7 @@
# 1. Server Naming Options:
# workgroup = NT-Domain-Name or Workgroup-Name
- workgroup = MDKGROUP
+ workgroup = WORKGROUP
# netbios name is the name you will see in "Network Neighbourhood",
# but defaults to your hostname
@@ -32,7 +32,6 @@
# 2. Printing Options:
# CHANGES TO ENABLE PRINTING ON ALL CUPS PRINTERS IN THE NETWORK
-# (as cups is now used in linux-mandrake 7.2 by default)
# if you want to automatically load your printer list rather
# than setting them up individually then you'll need this
printcap name = lpstat
@@ -281,13 +280,6 @@
; guest ok = yes
; writable = no
-#Uncomment the following 2 lines if you would like your login scripts to
-#be created dynamically by ntlogon (check that you have it in the correct
-#location (the default of the ntlogon rpm available in contribs - btw there
-#is no gentoo package for this; make one and submit it if you really want ;)
-;root preexec = /usr/bin/ntlogon -u %U -g %G -o %a -d /var/lib/samba/netlogon
-;root postexec = rm -f /var/lib/samba/netlogon/%U.bat
-
# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
diff --git a/net-fs/samba/samba-2.2.5.ebuild b/net-fs/samba/samba-2.2.5.ebuild
new file mode 100644
index 000000000000..e08a4f978a7e
--- /dev/null
+++ b/net-fs/samba/samba-2.2.5.ebuild
@@ -0,0 +1,312 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.5.ebuild,v 1.1 2002/06/23 20:56:52 woodchip Exp $
+
+DESCRIPTION="SAMBA is a suite of SMB and CIFS client/server programs for UNIX"
+HOMEPAGE="http://www.samba.org"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://us2.samba.org/samba/ftp/${P}.tar.gz"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/pam-0.72
+ acl? ( sys-apps/acl )
+ cups? ( net-print/cups )
+ ldap? ( =net-nds/openldap-2* )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ patch -p0 < ${FILESDIR}/samba-2.2.2-smbmount.diff || die
+
+ # fix kerberos include file collision..
+ cd ${S}/source/include
+ mv profile.h smbprofile.h
+ sed -e "s:profile\.h:smbprofile.h:" includes.h > includes.h.new
+ mv includes.h.new includes.h
+
+ #cd ${S}/source
+ #autoconf || die
+}
+
+src_compile() {
+ local myconf
+ use acl && myconf="${myconf} --with-acl-support"
+ use acl || myconf="${myconf} --without-acl-support"
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl"
+ use cups && myconf="${myconf} --enable-cups"
+ use cups || myconf="${myconf} --disable-cups"
+ use ldap && myconf="${myconf} --with-ldapsam"
+ use ldap || myconf="${myconf} --without-ldapsam"
+
+ cd ${S}/source
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --libdir=/etc/samba \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var/log \
+ --with-configdir=/etc/samba \
+ --with-mandir=/usr/share/man \
+ --with-piddir=/var/run/samba \
+ --with-lockdir=/var/run/samba \
+ --with-swatdir=/usr/share/swat \
+ --with-privatedir=/etc/samba/private \
+ --with-codepagedir=/var/lib/samba/codepages \
+ --with-pam --with-pam_smbpass \
+ --without-sambabook \
+ --without-automount \
+ --without-spinlocks \
+ --with-libsmbclient \
+ --with-smbwrapper \
+ --with-netatalk \
+ --with-smbmount \
+ --with-profile \
+ --with-quotas \
+ --with-syslog \
+ --with-msdfs \
+ --with-utmp \
+ --with-vfs \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make all smbfilter smbwrapper smbcacls pam_smbpass \
+ nsswitch nsswitch/libnss_wins.so debug2html
+ assert "compile problem"
+}
+
+src_install() {
+ local i
+
+ # we may as well do this all manually since it was starting
+ # to get out of control and samba _does_ have some rather
+ # silly installation quirks ;) much of this was adapted
+ # from mandrake's .spec file..
+ #
+ # // woodchip - 5 May 2002
+
+
+ # install standard binary files..
+ for i in nmblookup smbclient smbpasswd smbstatus testparm testprns \
+ make_smbcodepage make_unicodemap make_printerdef rpcclient \
+ smbspool smbcacls smbclient smbmount smbumount smbsh wbinfo
+ do
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ done
+ # make users lives easier..
+ fperms 4755 /usr/bin/smbumount
+
+
+ # libraries..
+ exeinto /usr/lib
+ doexe source/bin/smbwrapper.so
+ doexe source/bin/libsmbclient.so
+ insinto /usr/lib
+ doins source/bin/libsmbclient.a
+ exeinto /lib/security
+ doexe source/bin/pam_smbpass.so
+ doexe source/nsswitch/pam_winbind.so
+
+
+ # some utility scripts..
+ for i in mksmbpasswd.sh smbtar convert_smbpasswd
+ do
+ exeinto /usr/bin
+ doexe source/script/${i}
+ done
+
+
+ # install secure binary files..
+ for i in smbd nmbd swat smbfilter debug2html smbmnt smbcontrol winbindd
+ do
+ exeinto /usr/sbin
+ doexe source/bin/${i}
+ done
+ # make users lives easier..
+ fperms 4755 /usr/sbin/smbmnt
+
+
+ # install man pages..
+ doman docs/manpages/*
+
+
+ # install codepage source files
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251
+ do
+ insinto /var/lib/samba/codepages/src
+ doins source/codepages/codepage_def.${i}
+ done
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251 \
+ ISO8859-1 ISO8859-2 ISO8859-5 ISO8859-7 \
+ ISO8859-9 ISO8859-13 ISO8859-15 KOI8-R KOI8-U
+ do
+ insinto /var/lib/samba/codepages/src
+ doins source/codepages/CP${i}.TXT
+ done
+
+
+ # build codepage load files..
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251
+ do
+ ${D}/usr/bin/make_smbcodepage c ${i} \
+ ${D}/var/lib/samba/codepages/src/codepage_def.${i} \
+ ${D}/var/lib/samba/codepages/codepage.${i}
+ done
+
+
+ # build unicode load files..
+ for i in 437 737 775 850 852 857 861 862 866 932 936 949 950 1125 1251 \
+ ISO8859-1 ISO8859-2 ISO8859-5 ISO8859-7 \
+ ISO8859-9 ISO8859-13 ISO8859-15 KOI8-R KOI8-U
+ do
+ ${D}/usr/bin/make_unicodemap ${i} \
+ ${D}/var/lib/samba/codepages/src/CP${i}.TXT \
+ ${D}/var/lib/samba/codepages/unicode_map.${i}
+ done
+ rm -rf ${D}/var/lib/samba/codepages/src
+
+
+ # install the nsswitch library extension files..
+ for i in wins winbind
+ do
+ exeinto /lib
+ doexe source/nsswitch/libnss_${i}.so
+ done
+ # make link for wins and winbind resolvers..
+ ( cd ${D}/lib ; ln -s libnss_wins.so libnss_wins.so.2 )
+ ( cd ${D}/lib ; ln -s libnss_winbind.so libnss_winbind.so.2 )
+
+
+ # install SWAT helper files..
+ for i in swat/help/*.html docs/htmldocs/*.html
+ do
+ insinto /usr/share/swat/help
+ doins ${i}
+ done
+ for i in swat/images/*.gif
+ do
+ insinto /usr/share/swat/images
+ doins ${i}
+ done
+ for i in swat/include/*.html
+ do
+ insinto /usr/share/swat/include
+ doins ${i}
+ done
+
+
+ # install the O'Reilly "Using Samba" book..
+ for i in docs/htmldocs/using_samba/*.html
+ do
+ insinto /usr/share/swat/using_samba
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/gifs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/gifs
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/figs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/figs
+ doins ${i}
+ done
+
+
+ # too many docs to sort through; install them all! :)
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ # but we don't want two copies of the book!
+ rm -rf ${D}/usr/share/doc/${PF}/full_docs/htmldocs/using_samba
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+ # keep this next line *after* prepalldocs!
+ dosym /usr/share/swat/using_samba /usr/share/doc/${PF}/using_samba
+ # and we should unzip the html docs..
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/faq/*
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/htmldocs/*
+
+
+ # link /usr/bin/smbmount to /sbin/mount.smbfs which allows it
+ # to work transparently with the standard 'mount' command..
+ dodir /sbin
+ dosym /usr/bin/smbmount /sbin/mount.smbfs
+
+
+ # make the smb backend symlink for cups printing support..
+ if [ -n "`use cups`" ] ; then
+ dodir /usr/lib/cups/backend
+ dosym /usr/bin/smbspool /usr/lib/cups/backend/smb
+ fi
+
+
+ # make a symlink on /usr/lib/smbwrapper.so in /usr/bin
+ # to fix smbsh problem (another way to do that, anyone???)
+ dosym /usr/lib/smbwrapper.so /usr/bin/smbwrapper.so
+
+
+ # now the config files..
+ insinto /etc
+ doins ${FILESDIR}/nsswitch.conf-winbind
+ doins ${FILESDIR}/nsswitch.conf-wins
+
+ insinto /etc/samba
+ doins ${FILESDIR}/smbusers
+ doins ${FILESDIR}/smb.conf.example
+ doins ${FILESDIR}/lmhosts
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/samba.pam samba
+ doins ${FILESDIR}/system-auth-winbind
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/samba-init samba
+ newexe ${FILESDIR}/winbind-init winbind
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/swat.xinetd swat
+}
+
+pkg_postinst() {
+ # touch /etc/samba/smb.conf so that people installing samba just
+ # to mount smb shares don't get annoying warnings all the time..
+ if [ ! -e ${ROOT}/etc/samba/smb.conf ] ; then
+ touch ${ROOT}/etc/samba/smb.conf
+ fi
+
+
+ # empty dirs..
+ install -m0700 -o root -g root -d ${ROOT}/etc/samba/private
+ install -m1777 -o root -g root -d ${ROOT}/var/spool/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/log/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/run/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/samba/{netlogon,profiles}
+ install -m0755 -o root -g root -d \
+ ${ROOT}/var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC}
+
+
+ # im guessing people dont need this anymore, it was quite a while ago...
+ # /etc/smb is changed to /etc/samba, /var/run/smb to /var/run/samba
+ #ewarn "******************************************************************"
+ #ewarn "* NOTE: If you upgraded from an earlier version of samba you *"
+ #ewarn "* must move your /etc/smb files to the more aptly suited *"
+ #ewarn "* /etc/samba directory. Also, please move the files in *"
+ #ewarn "* /var/run/smb to /var/run/samba. Lastly, if you have *"
+ #ewarn "* the string "/etc/smb" in your smb.conf file, please *"
+ #ewarn "* change that to "/etc/samba". The old /etc/smb/codepages *"
+ #ewarn "* directory doesn't need to be moved into /etc/samba *"
+ #ewarn "* because those files are now kept in the *"
+ #ewarn "* /var/lib/samba/codepages directory. *"
+ #ewarn "******************************************************************"
+}