summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/picocom/picocom-1.6.ebuild')
-rw-r--r--net-dialup/picocom/picocom-1.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-dialup/picocom/picocom-1.6.ebuild b/net-dialup/picocom/picocom-1.6.ebuild
new file mode 100644
index 000000000000..d3180bcd4d41
--- /dev/null
+++ b/net-dialup/picocom/picocom-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/picocom/picocom-1.6.ebuild,v 1.1 2010/07/11 15:03:58 flameeyes Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="http://code.google.com/p/picocom/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i -e 's:\./picocom:picocom:' pcasc
+}
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm} || die
+ doman picocom.8 || die
+ dohtml picocom.8.html || die
+ dodoc CHANGES CHANGES.old CONTRIBUTORS NEWS README TODO || die
+}