summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/mgetty')
-rw-r--r--net-dialup/mgetty/ChangeLog11
-rw-r--r--net-dialup/mgetty/mgetty-1.1.37-r1.ebuild (renamed from net-dialup/mgetty/mgetty-1.1.37.ebuild)8
2 files changed, 15 insertions, 4 deletions
diff --git a/net-dialup/mgetty/ChangeLog b/net-dialup/mgetty/ChangeLog
index 452f59db0ce1..5d077e1ce13b 100644
--- a/net-dialup/mgetty/ChangeLog
+++ b/net-dialup/mgetty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/mgetty
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.104 2013/03/02 16:45:05 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/ChangeLog,v 1.105 2014/04/03 19:39:34 tomwij Exp $
+
+*mgetty-1.1.37-r1 (03 Apr 2014)
+
+ 03 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +mgetty-1.1.37-r1.ebuild,
+ -mgetty-1.1.37.ebuild:
+ [QA] Revision bump. Support user's CFLAGS and LDFLAGS; fixes bug #331953,
+ reported by Diego.
02 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> mgetty-1.1.37.ebuild:
Fix sed's paths in src_prepare, fix problem with doc building and
diff --git a/net-dialup/mgetty/mgetty-1.1.37.ebuild b/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
index b86ca2fff385..c72e325224dc 100644
--- a/net-dialup/mgetty/mgetty-1.1.37.ebuild
+++ b/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.37.ebuild,v 1.2 2013/03/02 16:45:05 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mgetty/mgetty-1.1.37-r1.ebuild,v 1.1 2014/04/03 19:39:34 tomwij Exp $
EAPI=5
inherit eutils flag-o-matic toolchain-funcs user
@@ -57,6 +57,10 @@ src_prepare() {
-e "s/^all:/all: doc-all/" \
doc/Makefile || die 'second sed on doc/Makefile failed'
fi
+
+ # Support user's CFLAGS and LDFLAGS.
+ sed -e "s/\$(CFLAGS) -o newslock/${CFLAGS} ${LDFLAGS} -Wall -o newslock/" \
+ -e "s/\$(LDLAGS)/${LDFLAGS}/" -i {,fax/}Makefile || die
}
src_compile() {