summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ettercap')
-rw-r--r--net-analyzer/ettercap/ChangeLog5
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.0.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/net-analyzer/ettercap/ChangeLog b/net-analyzer/ettercap/ChangeLog
index e366b774bf5a..675de6b8785f 100644
--- a/net-analyzer/ettercap/ChangeLog
+++ b/net-analyzer/ettercap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ettercap
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.35 2004/08/05 23:33:43 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ChangeLog,v 1.36 2004/08/13 16:36:05 eldad Exp $
+
+ 13 Aug 2004; Eldad Zack <eldad@gentoo.org> ettercap-0.7.0.ebuild:
+ Re-fix -ssl issue
05 Aug 2004; Jon Hood <squinky86@gentoo.org> ettercap-0.7.0.ebuild:
Stable on x86. Include fix from Alberto <alor@antifork.org>, #59003.
diff --git a/net-analyzer/ettercap/ettercap-0.7.0.ebuild b/net-analyzer/ettercap/ettercap-0.7.0.ebuild
index a4ee081b57b7..ce37aacfcf6d 100644
--- a/net-analyzer/ettercap/ettercap-0.7.0.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.0.ebuild,v 1.3 2004/08/05 23:33:43 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.0.ebuild,v 1.4 2004/08/13 16:36:05 eldad Exp $
# the actual version is "NG-0.7.0" but I suppose portage people will not be
@@ -41,10 +41,17 @@ src_unpack() {
}
src_compile() {
- econf \
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
`use_enable gtk gtk` \
`use_enable debug debug` \
- `use_with ssl openssl=/usr` \
`use_with ncurses ncurses` \
|| die "econf failed"