summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/jubler/files/jubler-3.4.1.patch')
-rw-r--r--media-video/jubler/files/jubler-3.4.1.patch190
1 files changed, 190 insertions, 0 deletions
diff --git a/media-video/jubler/files/jubler-3.4.1.patch b/media-video/jubler/files/jubler-3.4.1.patch
new file mode 100644
index 000000000000..35b6ec8c06a6
--- /dev/null
+++ b/media-video/jubler/files/jubler-3.4.1.patch
@@ -0,0 +1,190 @@
+diff -Nur Jubler-3.4.1/build.xml Jubler-3.4.1_patched/build.xml
+--- Jubler-3.4.1/build.xml 2007-11-22 16:20:30.000000000 +0200
++++ Jubler-3.4.1_patched/build.xml 2007-11-24 22:46:46.000000000 +0200
+@@ -69,22 +69,6 @@
+
+
+
+- <!-- Define new ant tasks -->
+-
+- <taskdef name="izpack"
+- onerror="report"
+- classpath="../TOOLS/IzPack/standalone-compiler.jar"
+- classname="com.izforge.izpack.ant.IzPackTask"/>
+-
+- <taskdef name="launch4j"
+- onerror="report"
+- classpath="../TOOLS/launch4j/launch4j.jar:../TOOLS/launch4j/lib/xstream.jar"
+- classname="net.sf.launch4j.ant.Launch4jTask"/>
+-
+- <taskdef name="jarbundler"
+- onerror="report"
+- classpath="../TOOLS/jarbundler/jarbundler-1.9.jar"
+- classname="net.sourceforge.jarbundler.JarBundler" />
+
+
+
+@@ -396,9 +380,6 @@
+
+
+
+- <target name="-pre-compile">
+- <copy todir="src/com"> <fileset dir="resources/system/no_mac"/> </copy>
+- </target>
+ <target name="-post-compile">
+ <delete dir="build/classes/com/apple" failonerror="false"/>
+ <delete dir="src/com/apple" failonerror="false"/>
+diff -Nur Jubler-3.4.1/resources/ffdecode/Makefile Jubler-3.4.1_patched/resources/ffdecode/Makefile
+--- Jubler-3.4.1/resources/ffdecode/Makefile 2007-11-24 20:59:29.000000000 +0200
++++ Jubler-3.4.1_patched/resources/ffdecode/Makefile 2007-11-24 22:47:54.000000000 +0200
+@@ -12,9 +12,6 @@
+ # Name of the produced library
+ PROJ=ffdecode
+
+-# Paths of include files
+-JAVA_HOME=${shell /bin/sh ../system/findjava.sh -j}
+-
+ # Path of the local ffmpeg source structure (already inside the source version of Jubler)
+ FFMPEG=../ffmpeg-svn
+
+@@ -40,7 +37,7 @@
+ SRCS=${shell ls 2>/dev/null *.c}
+ OBJS=${SRCS:.c=.o}
+
+-COMPFLAGS=${CFLAGS} -std=c99 -pedantic -O3 -Wall -fPIC
++COMPFLAGS=${CFLAGS} -std=c99 -pedantic -Wall -fPIC
+
+ ifeq (${STATIC},no)
+ FFMPEGREQ=
+@@ -98,7 +95,6 @@
+
+ FCONFCOMMON=--disable-debug --enable-gpl --disable-ffmpeg --disable-ffserver --disable-ffplay --disable-encoders --disable-muxers --enable-muxer=wav --disable-vhook --disable-ipv6 --disable-network --disable-libdc1394
+
+-CC=${PREF}gcc ${GCCOPTS}
+ RANLIB=${PREF}ranlib
+
+
+@@ -153,8 +149,6 @@
+
+ ${LIBNAME}:${FFMPEGREQ} ${OBJS} ${RANLIBREQ}
+ ${LD} ${GCCOPTS} -o ${LIBNAME} ${OBJS} ${LIBS}
+- ${STRIP} ${LIBNAME}
+-
+
+ clean:
+ rm -f *.o
+diff -Nur Jubler-3.4.1/src/com/panayotis/jubler/information/HelpBrowser.java Jubler-3.4.1_patched/src/com/panayotis/jubler/information/HelpBrowser.java
+--- Jubler-3.4.1/src/com/panayotis/jubler/information/HelpBrowser.java 2007-11-15 01:00:52.000000000 +0200
++++ Jubler-3.4.1_patched/src/com/panayotis/jubler/information/HelpBrowser.java 2007-11-24 22:48:42.000000000 +0200
+@@ -47,7 +47,7 @@
+
+ history = new ArrayList<String>();
+
+- String initpage = "file:"+SystemFileFinder.getJublerAppPath()+"/help/jubler-faq.html";
++ String initpage = "file:"+SystemFileFinder.getJublerAppPath()+"/../help/jubler-faq.html";
+ setPage(initpage);
+ history.add(initpage);
+
+diff -Nur Jubler-3.4.1/src/com/panayotis/jubler/Main.java Jubler-3.4.1_patched/src/com/panayotis/jubler/Main.java
+--- Jubler-3.4.1/src/com/panayotis/jubler/Main.java 2007-11-22 16:53:44.000000000 +0200
++++ Jubler-3.4.1_patched/src/com/panayotis/jubler/Main.java 2007-11-24 22:49:14.000000000 +0200
+@@ -84,17 +84,9 @@
+ /* Load arguments, in a mac way */
+ SystemDependent.initApplication();
+
+- /* Check current version in a new thread */
+- Thread versioncheck = new Thread() {
+- public void run() {
+- StaticJubler.initVersion();
+- }
+- };
+-
+ new Jubler(); // Display initial Jubler window
+ splash.dispose(); // Hide splash screen
+ loader.start(); // initialize loader
+- versioncheck.start();
+
+ }
+
+diff -Nur Jubler-3.4.1/src/com/panayotis/jubler/os/SystemDependent.java Jubler-3.4.1_patched/src/com/panayotis/jubler/os/SystemDependent.java
+--- Jubler-3.4.1/src/com/panayotis/jubler/os/SystemDependent.java 2007-11-18 14:10:12.000000000 +0200
++++ Jubler-3.4.1_patched/src/com/panayotis/jubler/os/SystemDependent.java 2007-11-24 22:50:54.000000000 +0200
+@@ -25,10 +25,6 @@
+
+ import static com.panayotis.jubler.i18n.I18N._;
+
+-import com.apple.eawt.Application;
+-import com.apple.eawt.ApplicationAdapter;
+-import com.apple.eawt.ApplicationEvent;
+-
+ import com.panayotis.jubler.Jubler;
+ import com.panayotis.jubler.Main;
+ import com.panayotis.jubler.StaticJubler;
+@@ -104,10 +100,6 @@
+
+
+ public static void initApplication() {
+- /* In Linux this is a dummy function */
+- if (isMacOSX()) {
+- JublerApp japp = new JublerApp();
+- }
+ }
+
+
+@@ -322,36 +314,3 @@
+ return home+".jubler/output.log";
+ }
+ }
+-
+-
+-
+-class JublerApp extends Application {
+- public JublerApp() {
+- setEnabledPreferencesMenu(true);
+- addApplicationListener(new ApplicationHandler());
+- }
+-}
+-
+-class ApplicationHandler extends ApplicationAdapter {
+-
+- public ApplicationHandler() {}
+-
+- public void handleAbout(ApplicationEvent event) {
+- StaticJubler.showAbout();
+- event.setHandled(true);
+- }
+-
+- public void handlePreferences(ApplicationEvent event) {
+- Jubler.prefs.showPreferencesDialog();
+- event.setHandled(true);
+- }
+-
+- public void handleQuit(ApplicationEvent event) {
+- StaticJubler.quitAll();
+- event.setHandled(false);
+- }
+-
+- public void handleOpenFile(ApplicationEvent event) {
+- Main.asyncAddSubtitle(event.getFilename());
+- }
+-}
+diff -Nur Jubler-3.4.1/src/com/panayotis/jubler/os/SystemFileFinder.java Jubler-3.4.1_patched/src/com/panayotis/jubler/os/SystemFileFinder.java
+--- Jubler-3.4.1/src/com/panayotis/jubler/os/SystemFileFinder.java 2007-11-15 00:52:55.000000000 +0200
++++ Jubler-3.4.1_patched/src/com/panayotis/jubler/os/SystemFileFinder.java 2007-11-24 22:51:52.000000000 +0200
+@@ -58,15 +58,12 @@
+ }
+
+ public static boolean loadLibrary(String name) {
+- File libfile = findFile("lib"+pathseparator+System.mapLibraryName(name));
+- if (libfile!=null) {
+ try {
+- System.load(libfile.getAbsolutePath());
++ System.loadLibrary(name);
+ return true;
+ } catch (UnsatisfiedLinkError e) {
+ e.printStackTrace();
+ }
+- }
+ return false;
+ }
+