summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild')
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild b/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild
new file mode 100644
index 000000000000..22e0e61b6c22
--- /dev/null
+++ b/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpcpp/ncmpcpp-0.2.3.ebuild,v 1.1 2008/09/23 22:23:50 yngwin Exp $
+
+inherit eutils
+
+DESCRIPTION="An ncurses mpd client, ncmpc clone with some new features, written in C++"
+HOMEPAGE="http://unkart.ovh.org/ncmpcpp"
+SRC_URI="http://unkart.ovh.org/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+IUSE="curl taglib unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ curl? ( net-misc/curl )
+ taglib? ( media-libs/taglib )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use sys-libs/ncurses unicode && use unicode ; then
+ eerror "Please recompile sys-libs/ncurses with the unicode useflag"
+ die
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode) $(use_with curl) $(use_with taglib) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" docdir="${ROOT}/usr/share/doc/${PF}" \
+ || die "install failed"
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ elog "Example configuration files have been installed at"
+ elog "${ROOT}usr/share/doc/${PF}"
+ echo
+}