summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/xlog/xlog-1.1.ebuild')
-rw-r--r--media-radio/xlog/xlog-1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-radio/xlog/xlog-1.1.ebuild b/media-radio/xlog/xlog-1.1.ebuild
new file mode 100644
index 000000000000..095716afc6ab
--- /dev/null
+++ b/media-radio/xlog/xlog-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-1.1.ebuild,v 1.1 2005/02/16 06:11:00 killsoft Exp $
+
+DESCRIPTION="GTK+ Amateur Radio logging program"
+HOMEPAGE="http://www.qsl.net/pg4i/linux/xlog.html"
+SRC_URI="http://www.qsl.net/pg4i/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11
+ >=gnome-base/libgnomeprint-2.4.0
+ >=x11-libs/gtk+-2.4.0-r1
+ >=media-libs/hamlib-1.2.3"
+
+DEPEND="sys-devel/libtool
+ >=app-doc/doxygen-1.3.5-r1
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ econf --enable-hamlib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+ make_desktop_entry xlog XLog xlog.xpm HamRadio
+}