summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/taglib')
-rw-r--r--media-libs/taglib/ChangeLog6
-rw-r--r--media-libs/taglib/files/taglib-1.7-security.patch30
-rw-r--r--media-libs/taglib/taglib-1.7-r1.ebuild49
3 files changed, 5 insertions, 80 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index a57eca597a75..a1855fc655c4 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.120 2012/04/17 21:24:02 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.121 2012/04/17 21:43:40 johu Exp $
+
+ 17 Apr 2012; Johannes Huber <johu@gentoo.org>
+ -files/taglib-1.7-security.patch, -taglib-1.7-r1.ebuild:
+ Remove old wrt bug #410953.
17 Apr 2012; Brent Baude <ranger@gentoo.org> taglib-1.7.1.ebuild:
Marking taglib-1.7.1 ppc64 for bug 410953
diff --git a/media-libs/taglib/files/taglib-1.7-security.patch b/media-libs/taglib/files/taglib-1.7-security.patch
deleted file mode 100644
index 47765b3dc19f..000000000000
--- a/media-libs/taglib/files/taglib-1.7-security.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-http://bugs.gentoo.org/407673
-
-CVE-2012-1107
-http://github.com/taglib/taglib/commit/77d61c6eca4d08b9b025738acf6b926cc750db23
-
-CVE-2012-1108
-http://github.com/taglib/taglib/commit/ab8a0ee8937256311e649a88e8ddd7c7f870ad59
-
---- taglib/ape/apeproperties.cpp
-+++ taglib/ape/apeproperties.cpp
-@@ -193,7 +193,7 @@
- uint blocksPerFrame = header.mid(4, 4).toUInt(false);
- uint finalFrameBlocks = header.mid(8, 4).toUInt(false);
- uint totalBlocks = totalFrames > 0 ? (totalFrames - 1) * blocksPerFrame + finalFrameBlocks : 0;
-- d->length = totalBlocks / d->sampleRate;
-+ d->length = d->sampleRate > 0 ? totalBlocks / d->sampleRate : 0;
- d->bitrate = d->length > 0 ? ((d->streamLength * 8L) / d->length) / 1000 : 0;
- }
-
---- taglib/ogg/xiphcomment.cpp
-+++ taglib/ogg/xiphcomment.cpp
-@@ -287,7 +287,7 @@
-
- int pos = 0;
-
-- int vendorLength = data.mid(0, 4).toUInt(false);
-+ uint vendorLength = data.mid(0, 4).toUInt(false);
- pos += 4;
-
- d->vendorID = String(data.mid(pos, vendorLength), String::UTF8);
diff --git a/media-libs/taglib/taglib-1.7-r1.ebuild b/media-libs/taglib/taglib-1.7-r1.ebuild
deleted file mode 100644
index 05a948927792..000000000000
--- a/media-libs/taglib/taglib-1.7-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.7-r1.ebuild,v 1.7 2012/03/17 17:33:44 armin76 Exp $
-
-EAPI=4
-inherit cmake-utils
-
-DESCRIPTION="A library for reading and editing audio meta data"
-HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
-SRC_URI="http://developer.kde.org/~wheeler/files/src/${P}.tar.gz"
-
-LICENSE="LGPL-2 MPL-1.1"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-SLOT="0"
-IUSE="+asf debug examples +mp4 test"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.1-install-examples.patch
- "${FILESDIR}"/${P}-security.patch
- )
-
-DOCS="AUTHORS NEWS"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_build examples)
- $(cmake-utils_use_with asf)
- $(cmake-utils_use_with mp4)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if ! use asf; then
- elog "You've chosen to disable the asf use flag, thus taglib won't include"
- elog "support for Microsoft's 'advanced systems format' media container"
- fi
- if ! use mp4; then
- elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
- elog "support for the MPEG-4 part 14 / MP4 media container"
- fi
-}