summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/ChangeLog9
-rw-r--r--media-libs/harfbuzz/harfbuzz-0.9.17.ebuild57
-rw-r--r--media-libs/harfbuzz/harfbuzz-0.9.20.ebuild72
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild22
4 files changed, 94 insertions, 66 deletions
diff --git a/media-libs/harfbuzz/ChangeLog b/media-libs/harfbuzz/ChangeLog
index 0322b02f3dfd..4348bf5dd61f 100644
--- a/media-libs/harfbuzz/ChangeLog
+++ b/media-libs/harfbuzz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/harfbuzz
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.44 2013/07/13 08:18:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.45 2013/09/02 19:28:22 tetromino Exp $
+
+*harfbuzz-0.9.20 (02 Sep 2013)
+
+ 02 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -harfbuzz-0.9.17.ebuild, +harfbuzz-0.9.20.ebuild, harfbuzz-9999.ebuild:
+ Version bump; fixes various bugs, adds API docs and experimental
+ gobject-introspection support. Drop old.
13 Jul 2013; Fabian Groffen <grobian@gentoo.org> harfbuzz-0.9.18-r1.ebuild:
Fix linking on Solaris, same fix as necessary for Darwin
diff --git a/media-libs/harfbuzz/harfbuzz-0.9.17.ebuild b/media-libs/harfbuzz/harfbuzz-0.9.17.ebuild
deleted file mode 100644
index 8ee5ba2dcbcc..000000000000
--- a/media-libs/harfbuzz/harfbuzz-0.9.17.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.17.ebuild,v 1.1 2013/05/21 10:31:14 scarabeus Exp $
-
-EAPI=5
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
-[[ ${PV} == 9999 ]] && inherit git-2 autotools
-
-inherit eutils libtool
-
-DESCRIPTION="An OpenType text shaping engine"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
-[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
-
-LICENSE="Old-MIT ISC icu"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-macos ~x64-solaris"
-IUSE="static-libs"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/icu:=
- media-gfx/graphite2:=
- media-libs/freetype:2=
- x11-libs/cairo:=
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # on Darwin we need to link with g++, like automake defaults to,
- # but overridden by upstream because on Linux this is not
- # necessary, bug #449126
- sed -i \
- -e 's/\<LINK\>/CXXLINK/' \
- src/Makefile.am || die
- sed -i \
- -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
- src/Makefile.in || die
- fi
- [[ ${PV} == 9999 ]] && eautoreconf
- elibtoolize # for building a shared library on x64-solaris
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- prune_libtool_files --modules
-}
diff --git a/media-libs/harfbuzz/harfbuzz-0.9.20.ebuild b/media-libs/harfbuzz/harfbuzz-0.9.20.ebuild
new file mode 100644
index 000000000000..445997546f58
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-0.9.20.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.20.ebuild,v 1.1 2013/09/02 19:28:22 tetromino Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-2 autotools
+
+inherit eutils libtool autotools
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-macos ~x64-solaris"
+# TODO: +introspection when it's closer to finished and useful (0.9.21 hopefully)
+IUSE="+cairo +glib +graphite icu introspection static-libs +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( dev-libs/glib:2 )
+ graphite? ( media-gfx/graphite2:= )
+ icu? ( dev-libs/icu:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )
+ truetype? ( media-libs/freetype:2= )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/gtk-doc-am
+ dev-util/ragel
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(use_with cairo) \
+ $(use_with glib) \
+ $(use_with glib gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(use_enable introspection) \
+ $(use_with truetype freetype)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index dd7e4cf2281c..5ea7ec16ccf6 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.15 2013/06/06 05:23:28 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.16 2013/09/02 19:28:22 tetromino Exp $
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
[[ ${PV} == 9999 ]] && inherit git-2 autotools
-inherit eutils libtool
+inherit eutils libtool autotools
DESCRIPTION="An OpenType text shaping engine"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
@@ -17,24 +17,29 @@ LICENSE="Old-MIT ISC icu"
SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
[[ ${PV} == 9999 ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-macos ~x64-solaris"
-IUSE="+cairo +glib +graphite icu static-libs +truetype"
+# TODO: +introspection when it's closer to finished and useful (0.9.21 hopefully)
+IUSE="+cairo +glib +graphite icu introspection static-libs +truetype"
+REQUIRED_USE="introspection? ( glib )"
RDEPEND="
cairo? ( x11-libs/cairo:= )
glib? ( dev-libs/glib:2 )
graphite? ( media-gfx/graphite2:= )
icu? ( dev-libs/icu:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.32 )
truetype? ( media-libs/freetype:2= )
"
DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/gtk-doc-am
dev-util/ragel
virtual/pkgconfig
"
src_prepare() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # on Darwin we need to link with g++, like automake defaults to,
- # but overridden by upstream because on Linux this is not
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
# necessary, bug #449126
sed -i \
-e 's/\<LINK\>/CXXLINK/' \
@@ -43,8 +48,8 @@ src_prepare() {
-e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
src/Makefile.in || die
fi
+
[[ ${PV} == 9999 ]] && eautoreconf
- elibtoolize # for building a shared library on x64-solaris
}
src_configure() {
@@ -54,10 +59,11 @@ src_configure() {
$(use_enable static-libs static) \
$(use_with cairo) \
$(use_with glib) \
+ $(use_with glib gobject) \
$(use_with graphite graphite2) \
$(use_with icu) \
+ $(use_enable introspection) \
$(use_with truetype freetype)
-
}
src_install() {