summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pqiv/pqiv-0.11.ebuild')
-rw-r--r--media-gfx/pqiv/pqiv-0.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/pqiv/pqiv-0.11.ebuild b/media-gfx/pqiv/pqiv-0.11.ebuild
new file mode 100644
index 000000000000..6d9e9c15f43c
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pqiv/pqiv-0.11.ebuild,v 1.1 2010/06/22 08:34:56 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="http://www.pberndt.com/Programme/Linux/pqiv"
+SRC_URI="http://www.pberndt.com/raw/Programme/Linux/${PN}/_download/${P}.tbz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ ./configure --prefix=/usr --destdir="${D}" || die
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ emake install || die
+ dodoc README
+}