summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild')
-rw-r--r--mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild b/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild
index a2f98d1b8108..22637284aa0d 100644
--- a/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild
+++ b/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild,v 1.8 2008/01/10 17:06:36 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/squirrelmail/squirrelmail-1.4.10a-r2.ebuild,v 1.9 2008/11/02 06:08:11 jmbsvicetto Exp $
IUSE="crypt ldap spell ssl filter mysql postgres nls"
@@ -56,14 +56,14 @@ src_unpack() {
unpack ${MY_P}.tar.bz2
unpack squirrelmail-decode-${DECODING_VER}.tar.bz2
- cd ${S}
+ cd "${S}"
mv config/config_default.php config/config.php
sed -i "s:'/var/local/squirrelmail/data/':SM_PATH . 'data/':" config/config.php
# Now do the plugins
- cd ${S}/plugins
+ cd "${S}"/plugins
sed -i 's:/usr/games/fortune:/usr/bin/fortune:g' fortune/setup.php || die "Unable to fix fortunes plugin."
@@ -82,7 +82,7 @@ src_unpack() {
use ldap &&
unpack ldapuserdata-${LDAP_USERDATA_VER}.tar.gz &&
- epatch ${FILESDIR}/ldapuserdata-${LDAP_USERDATA_VER}-gentoo.patch &&
+ epatch "${FILESDIR}/ldapuserdata-${LDAP_USERDATA_VER}-gentoo.patch" &&
mv ldapuserdata/config_sample.php ldapuserdata/config.php
use ssl &&
@@ -92,11 +92,11 @@ src_unpack() {
mv show_ssl_link/config.php.sample show_ssl_link/config.php
use nls &&
- cd ${S} &&
+ cd "${S}" &&
unpack all_locales-${LOCALES_VER}.tar.bz2
- cd ${S}
- use crypt && epatch ${FILESDIR}/squirrelmail-gpg-2.1-CVE-2005-1924.patch
+ cd "${S}"
+ use crypt && epatch "${FILESDIR}"/squirrelmail-gpg-2.1-CVE-2005-1924.patch
}
src_compile() {
@@ -176,9 +176,9 @@ src_install() {
# Copy the app's main files
einfo "Installing squirrelmail files."
- cp -r . ${D}${MY_HTDOCSDIR}
+ cp -r . "${D}${MY_HTDOCSDIR}"
- cp ${WORKDIR}/squirrelmail-decode-${DECODING_VER}/*/*.php ${D}${MY_HTDOCSDIR}/functions/decode
+ cp "${WORKDIR}/squirrelmail-decode-${DECODING_VER}/*/*.php" "${D}${MY_HTDOCSDIR}/functions/decode"
# Identify the configuration files that this app uses
local configs="config/config.php config/config_local.php plugins/retrieveuserdata/config.php"
@@ -207,7 +207,7 @@ src_install() {
done
# add the post-installation instructions
- webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
# all done
#