summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.7.4.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 64c0050f166f..a6b8901c2ae9 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.91 2011/12/07 23:07:54 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.92 2011/12/11 18:52:33 alexxy Exp $
+
+*step-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +step-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org> -step-4.7.2.ebuild:
Drop KDE 4.7.2
diff --git a/kde-base/step/step-4.7.4.ebuild b/kde-base/step/step-4.7.4.ebuild
new file mode 100644
index 000000000000..283fe061a9ca
--- /dev/null
+++ b/kde-base/step/step-4.7.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.7.4.ebuild,v 1.1 2011/12/11 18:52:33 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+ kde4-base_src_configure
+}