summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog5
-rw-r--r--kde-base/korundum/korundum-4.14.0.ebuild72
2 files changed, 4 insertions, 73 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index e201c73ccb8b..55f34f1309e8 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.224 2014/10/25 19:58:36 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.225 2014/10/25 20:40:49 mrueg Exp $
+
+ 25 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -korundum-4.14.0.ebuild:
+ Cleanup KDE SC 4.14.0
*korundum-4.14.2 (25 Oct 2014)
diff --git a/kde-base/korundum/korundum-4.14.0.ebuild b/kde-base/korundum/korundum-4.14.0.ebuild
deleted file mode 100644
index 16c385fad4ee..000000000000
--- a/kde-base/korundum/korundum-4.14.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.14.0.ebuild,v 1.1 2014/08/20 16:02:51 johu Exp $
-
-EAPI=5
-
-OPENGL_REQUIRED="always"
-
-USE_RUBY="ruby19"
-# Only one ruby version is supported:
-# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
-# files with identical path+name will overwrite each other - difficult :(
-
-inherit kde4-base ruby-ng
-
-DESCRIPTION="KDE Ruby bindings"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="akonadi debug kate nepomuk okular"
-HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
-
-DEPEND="
- $(add_kdebase_dep qtruby)
- $(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,nepomuk?')
- $(add_kdebase_dep smokeqt)
-"
-RDEPEND="${DEPEND}
-"
-
-pkg_setup() {
- ruby-ng_pkg_setup
- kde4-base_pkg_setup
-}
-
-src_unpack() {
- local S="${WORKDIR}/${P}"
- kde4-base_src_unpack
-
- cd "${WORKDIR}"
- mkdir all
- mv ${P} all/ || die "Could not move sources"
-}
-
-all_ruby_prepare() {
- kde4-base_src_prepare
-}
-
-each_ruby_configure() {
- CMAKE_USE_DIR=${S}
- local mycmakeargs=(
- -DRUBY_LIBRARY=$(ruby_get_libruby)
- -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
- -DRUBY_EXECUTABLE=${RUBY}
- $(cmake-utils_use_with akonadi)
- $(cmake-utils_use_with akonadi KdepimLibs)
- $(cmake-utils_use_with nepomuk)
- $(cmake-utils_use_with nepomuk Soprano)
- $(cmake-utils_use_disable kate)
- $(cmake-utils_use_with okular)
- )
- kde4-base_src_configure
-}
-
-each_ruby_compile() {
- CMAKE_USE_DIR=${S}
- kde4-base_src_compile
-}
-
-each_ruby_install() {
- CMAKE_USE_DIR=${S}
- kde4-base_src_install
-}