summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kalgebra/kalgebra-4.14.3.ebuild')
-rw-r--r--kde-apps/kalgebra/kalgebra-4.14.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-apps/kalgebra/kalgebra-4.14.3.ebuild b/kde-apps/kalgebra/kalgebra-4.14.3.ebuild
new file mode 100644
index 000000000000..b1af1e682dae
--- /dev/null
+++ b/kde-apps/kalgebra/kalgebra-4.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-apps/kalgebra/kalgebra-4.14.3.ebuild,v 1.1 2015/06/04 18:44:42 kensington Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE"
+HOMEPAGE="http://www.kde.org/applications/education/kalgebra
+http://edu.kde.org/kalgebra"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep analitza opengl?)
+ $(add_kdeapps_dep libkdeedu)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}