summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild
new file mode 100644
index 000000000000..211beb0192bd
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.6.ebuild,v 1.1 2005/06/06 05:00:28 fafhrd Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+PROVIDE="virtual/gnustep-back"
+
+IUSE="${IUSE} opengl xim doc"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-make-1.10.0
+ ~gnustep-base/gnustep-base-1.10.3
+ ~gnustep-base/gnustep-gui-0.9.5
+ virtual/xft
+ opengl? ( virtual/opengl virtual/glu )"
+RDEPEND="${DEPEND}
+ ${DEBUG_DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/font-make-fix.patch-0.9.5
+}
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib --with-name=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+