summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-2.28.1.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-2.28.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-2.28.1.ebuild b/gnome-extra/gucharmap/gucharmap-2.28.1.ebuild
new file mode 100644
index 000000000000..78ce538b9342
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-2.28.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/gucharmap-2.28.1.ebuild,v 1.1 2009/10/29 21:58:59 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Unicode character map viewer"
+HOMEPAGE="http://gucharmap.sourceforge.net/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cjk doc gnome python test"
+
+# FIXME: add gobject-introspection support once available
+RDEPEND=">=dev-libs/glib-2.16.3
+ >=x11-libs/pango-1.2.1
+ >=x11-libs/gtk+-2.13.6
+ gnome? ( gnome-base/gconf )
+ python? ( >=dev-python/pygtk-2.7.1 )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.9.0
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )"
+
+DOCS="ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-maintainer-mode
+ $(use_enable gnome gconf)
+ $(use_enable cjk unihan)
+ $(use_enable python python-bindings)"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}