summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomekbd/ChangeLog9
-rw-r--r--gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-kbd-crash.patch46
-rw-r--r--gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-notification-area.patch24
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild49
4 files changed, 127 insertions, 1 deletions
diff --git a/gnome-base/libgnomekbd/ChangeLog b/gnome-base/libgnomekbd/ChangeLog
index 98e541962024..cd6713953132 100644
--- a/gnome-base/libgnomekbd/ChangeLog
+++ b/gnome-base/libgnomekbd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/libgnomekbd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/ChangeLog,v 1.70 2010/06/04 20:11:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/ChangeLog,v 1.71 2010/06/13 16:47:46 pacho Exp $
+
+*libgnomekbd-2.30.1 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +libgnomekbd-2.30.1.ebuild,
+ +files/libgnomekbd-2.30.1-kbd-crash.patch,
+ +files/libgnomekbd-2.30.1-notification-area.patch:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> libgnomekbd-2.28.2.ebuild:
x86 stable, bug #314899
diff --git a/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-kbd-crash.patch b/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-kbd-crash.patch
new file mode 100644
index 000000000000..44626a6339bc
--- /dev/null
+++ b/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-kbd-crash.patch
@@ -0,0 +1,46 @@
+From 4f9c7b401e948756fbe76a56a7619052f8acae42 Mon Sep 17 00:00:00 2001
+From: Sergey V. Udaltsov <svu@gnome.org>
+Date: Tue, 04 May 2010 23:36:04 +0000
+Subject: Do not crash on kbd plug in
+
+There is funny race condition in X - when _XKB_RULES_NAMES is already
+loaded from sysconfig while actual XKB config is still not changed (from
+user config). This commit should fix
+https://bugzilla.gnome.org/show_bug.cgi?id=617643
+---
+diff --git a/libgnomekbd/gkbd-indicator.c b/libgnomekbd/gkbd-indicator.c
+index 5def369..f6064fa 100644
+--- a/libgnomekbd/gkbd-indicator.c
++++ b/libgnomekbd/gkbd-indicator.c
+@@ -318,7 +318,7 @@ gkbd_indicator_extract_layout_name (int group, XklEngine * engine,
+ gchar ** short_group_names,
+ gchar ** full_group_names)
+ {
+- char *layout_name;
++ char *layout_name = NULL;
+ if (group < g_strv_length (short_group_names)) {
+ if (xkl_engine_get_features (engine) &
+ XKLF_MULTIPLE_LAYOUTS_SUPPORTED) {
+@@ -352,7 +352,7 @@ gkbd_indicator_extract_layout_name (int group, XklEngine * engine,
+ }
+
+ if (layout_name == NULL)
+- layout_name = g_strdup ("??");
++ layout_name = g_strdup ("");
+
+ return layout_name;
+ }
+diff --git a/libgnomekbd/gkbd-status.c b/libgnomekbd/gkbd-status.c
+index 90731af..efcad6a 100644
+--- a/libgnomekbd/gkbd-status.c
++++ b/libgnomekbd/gkbd-status.c
+@@ -152,6 +152,7 @@ gkbd_status_render_cairo (cairo_t * cr, int group)
+ cairo_font_options_t *fo;
+ static GHashTable *ln2cnt_map = NULL;
+
++ xkl_debug (160, "Rendering cairo for group %d\n", group);
+ if (globals.ind_cfg.background_color != NULL &&
+ globals.ind_cfg.background_color[0] != 0) {
+ if (sscanf
+--
+cgit v0.8.3.1
diff --git a/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-notification-area.patch b/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-notification-area.patch
new file mode 100644
index 000000000000..9acda770ea9f
--- /dev/null
+++ b/gnome-base/libgnomekbd/files/libgnomekbd-2.30.1-notification-area.patch
@@ -0,0 +1,24 @@
+From 8dbeec103124f9de1ed515ef50ff79eff3ecd52c Mon Sep 17 00:00:00 2001
+From: Sergey V. Udaltsov <svu@gnome.org>
+Date: Sun, 25 Apr 2010 22:59:53 +0000
+Subject: Provide the proper place in NA by using the name
+
+The name "keyboard" is known to the NA applet - so it positions the icon
+properly, on the right side, after all apps
+---
+diff --git a/libgnomekbd/gkbd-status.c b/libgnomekbd/gkbd-status.c
+index efcad6a..5e62ae9 100644
+--- a/libgnomekbd/gkbd-status.c
++++ b/libgnomekbd/gkbd-status.c
+@@ -632,6 +632,9 @@ gkbd_status_init (GkbdStatus * gki)
+
+ gki->priv = g_new0 (GkbdStatusPrivate, 1);
+
++ /* This should give NA a hint about the order */
++ gtk_status_icon_set_name (GTK_STATUS_ICON(gki), "keyboard");
++
+ xkl_debug (100, "Initiating the widget startup process for %p\n",
+ gki);
+
+--
+cgit v0.8.3.1
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild
new file mode 100644
index 000000000000..06a9a7eb7e40
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild,v 1.1 2010/06/13 16:47:46 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=sys-apps/dbus-0.92
+ >=dev-libs/dbus-glib-0.34
+ >=gnome-base/gconf-2.14
+ >=x11-libs/gtk+-2.18
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # Only user interaction required graphical tests at the time of 2.22.0 - not useful for us
+ G2CONF="${G2CONF} --disable-tests --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not crash on kbd plug in; upstream bug 617643
+ epatch "${FILESDIR}/${P}-kbd-crash.patch"
+
+ # Provide the proper place in NA by using the name
+ epatch "${FILESDIR}/${P}-notification-area.patch"
+}
+
+src_compile() {
+ # FreeBSD doesn't like -j, upstream? bug #????
+ use x86-fbsd && MAKEOPTS="${MAKEOPTS} -j1"
+ gnome2_src_compile
+}