summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.10.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.10.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnome-base/orbit/orbit-2.14.10.ebuild b/gnome-base/orbit/orbit-2.14.10.ebuild
index 748de75cd6de..e2f8ee69cbe9 100644
--- a/gnome-base/orbit/orbit-2.14.10.ebuild
+++ b/gnome-base/orbit/orbit-2.14.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.10.ebuild,v 1.7 2007/11/27 03:52:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.10.ebuild,v 1.8 2008/03/16 21:46:57 leio Exp $
inherit gnome2 eutils
@@ -28,6 +28,17 @@ MAKEOPTS="${MAKEOPTS} -j1"
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+src_unpack() {
+ gnome2_src_unpack
+
+ # Filter out G_DISABLE_DEPRECATED to work with glib-2.16 and be future-proof, bug 213434
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ "${S}/linc2/src/Makefile.am" "${S}/linc2/src/Makefile.in"
+
+ sed -i -e 's:-DG_DISABLE_DEPRECATED::g' \
+ "${S}/configure.in" "${S}/configure"
+}
+
src_compile() {
# We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
# files to be not found by autotools when compiling ORBit. See bug #58540