summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog7
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.5.29
-rw-r--r--games-simulation/openttd/openttd-0.5.2.ebuild189
3 files changed, 204 insertions, 1 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index f3d5549e3086..77b72424d192 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.41 2007/05/26 12:10:23 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.42 2007/05/30 22:46:38 pylon Exp $
+
+*openttd-0.5.2 (30 May 2007)
+
+ 30 May 2007; Lars Weiler <pylon@gentoo.org> +openttd-0.5.2.ebuild:
+ Bugfix release; revision bump.
26 May 2007; Christian Faulhammer <opfer@gentoo.org> openttd-0.5.0.ebuild:
amd64 stable, bug 175308
diff --git a/games-simulation/openttd/files/digest-openttd-0.5.2 b/games-simulation/openttd/files/digest-openttd-0.5.2
new file mode 100644
index 000000000000..d2263ee3f9e1
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-0.5.2
@@ -0,0 +1,9 @@
+MD5 34e8cb13ce1d4e6b5b24887c628c1ac8 openttd-0.4.8-scenarios.tar.bz2 5000799
+RMD160 a6c2fa9f81e4e4628adb9c3932dec46ab4789777 openttd-0.4.8-scenarios.tar.bz2 5000799
+SHA256 61788035bd78a3c0e393d5992432c37e0b6036d19a960543f26d43a46e39e6ca openttd-0.4.8-scenarios.tar.bz2 5000799
+MD5 37892f1fdded957f956766642a9e877d openttd-0.5.0-scenarios.tar.bz2 917117
+RMD160 f6ea4a4004bb0c90de9283a92b14da4bd99bc33c openttd-0.5.0-scenarios.tar.bz2 917117
+SHA256 c89e652aca1a9ad9f0f4936dd99cd8a9c96f4c53450990ff87d87483f8e74a31 openttd-0.5.0-scenarios.tar.bz2 917117
+MD5 7c16701724be67c614598577f980381d openttd-0.5.2-source.tar.bz2 3034368
+RMD160 77528fa6d558787cfc1349d821041f005f3262ab openttd-0.5.2-source.tar.bz2 3034368
+SHA256 c5a1753f32a87293130347eb440bd9e76ebf0299db5d6a19059ca4d52407d4b1 openttd-0.5.2-source.tar.bz2 3034368
diff --git a/games-simulation/openttd/openttd-0.5.2.ebuild b/games-simulation/openttd/openttd-0.5.2.ebuild
new file mode 100644
index 000000000000..aca9a8de27c4
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.5.2.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.2.ebuild,v 1.1 2007/05/30 22:46:38 pylon Exp $
+
+inherit eutils games
+
+SCENARIOS_048="${PN}-0.4.8-scenarios.tar.bz2"
+SCENARIOS_050="${PN}-0.5.0-scenarios.tar.bz2"
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SB="mirror://sourceforge/openttd"
+SRC_URI="${SB}/${P}-source.tar.bz2
+ scenarios? ( ${SB}/${SCENARIOS_048}
+ ${SB}/${SCENARIOS_050} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE="alsa debug dedicated iconv png scenarios timidity zlib"
+
+DEPEND="!dedicated? ( media-libs/libsdl
+ media-libs/fontconfig
+ )
+ iconv? ( virtual/libiconv )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/alsa-utils ) )
+ )"
+
+pkg_setup() {
+ if ! use dedicated && ! built_with_use media-libs/libsdl X ; then
+ die "Please emerge media-libs/libsdl with USE=X"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}-source.tar.bz2
+ if use scenarios ; then
+ cd ${S}/scenario/
+ unpack ${SCENARIOS_048}
+ unpack ${SCENARIOS_050}
+ fi
+ cd ${S}
+ # Don't pre-strip binaries (bug #137822)
+ sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
+ # Don't install into prefixed DATA_DIR
+ sed -i -e \
+ 's#DATA_DIR_PREFIXED:=$(PREFIX)/$(DATA_DIR)#DATA_DIR_PREFIXED:=$(DATA_DIR)#' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ local myopts=""
+ use debug && myopts="${myopts} DEBUG=1"
+ use dedicated && myopts="${myopts} DEDICATED=1"
+ use iconv && myopts="${myopts} WITH_ICONV=1"
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+ if ! use dedicated ; then
+ myopts="${myopts} WITH_SDL=1 WITH_FREETYPE=1 WITH_FONTCONFIG=1"
+ if ! use timidity; then
+ use alsa && myopts="${myopts} MIDI=/usr/bin/aplaymidi"
+ fi
+ fi
+
+ emake \
+ MANUAL_CONFIG=1 \
+ UNIX=1 \
+ WITH_NETWORK=1 \
+ INSTALL=1 \
+ USE_HOMEDIR=1 \
+ DEST_DIR=${D} \
+ PERSONAL_DIR=.openttd \
+ PREFIX=${GAMES_PREFIX} \
+ DATA_DIR=${GAMES_DATADIR}/${PN} \
+ CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
+ ${myopts} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed (data)"
+
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed (lang)"
+
+ if use scenarios ; then
+ insinto "${GAMES_DATADIR}/${PN}/scenario"
+ doins scenario/*.scn || die "doins failed (scenario)"
+ doins scenario/*/*.scn || die "doins failed (scenario)"
+ fi
+
+ insinto "${GAMES_DATADIR}/${PN}/scripts"
+ doins scripts/*.example || die "doins failed (scripts)"
+
+ for i in {16,32,48,64,128}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins media/openttd.${i}.png openttd.png
+ done
+
+ if ! use dedicated ; then
+ if use timidity || use alsa ; then
+ make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
+ else
+ make_desktop_entry openttd "OpenTTD" openttd
+ fi
+ else
+ newinitd "${FILESDIR}"/openttd.initd openttd
+ fi
+
+ dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt docs/multiplayer.txt
+ dohtml -a html,gif,png,svg docs/*
+ newdoc scripts/readme.txt readme_scripts.txt
+ doman docs/openttd.6
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ echo
+ einfo "From the WINDOWS version you need: "
+ einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo "OR from the DOS version you need: "
+ einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ echo
+ einfo "File names are case sensitive so make sure they are "
+ einfo "correct for whichever version you have."
+ echo
+
+ if ! use scenarios ; then
+ einfo "Scenarios are now included in a seperate package. To "
+ einfo "install them as well please remerge with the "
+ einfo "\"scenarios\" USE flag."
+ echo
+ else
+ einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
+ einfo "you will have to symlink them to ~/.openttd/scenario in order"
+ einfo "to use them."
+ einfo "Example:"
+ einfo " mkdir -p ~/.openttd/scenario"
+ einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+ echo
+ fi
+
+ if use dedicated ; then
+ einfo "You have chosen the dedicated USE flag which builds a "
+ einfo "version of OpenTTD to be used as a game server which "
+ einfo "does not require SDL. You will not be able to play the "
+ einfo "game, but if you don't pass this flag you can still use "
+ einfo "it as a server in the same way, but SDL will be required."
+ echo
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ echo
+ else
+ if use timidity || use alsa ; then
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ einfo "You can enable MIDI by running:"
+ einfo " openttd -m extmidi"
+ echo
+ if use timidity ; then
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "You have emerged with 'aplaymidi' for playing MIDI."
+ einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ einfo "Available ports can be listed by using 'aplaymidi -l'."
+ fi
+ else
+ einfo "timidity and/or alsa not in USE so music will not be played during the game."
+ fi
+ echo
+ fi
+}