summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crashtest/crashtest-1.0.ebuild')
-rw-r--r--games-simulation/crashtest/crashtest-1.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/games-simulation/crashtest/crashtest-1.0.ebuild b/games-simulation/crashtest/crashtest-1.0.ebuild
index 69379b56c79a..4de314f890fb 100644
--- a/games-simulation/crashtest/crashtest-1.0.ebuild
+++ b/games-simulation/crashtest/crashtest-1.0.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.1 2007/05/18 19:06:50 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crashtest/crashtest-1.0.ebuild,v 1.2 2007/05/22 02:38:11 nyhm Exp $
inherit eutils games
-DESCRIPTION="Simulates car crashes"
-HOMEPAGE="http://stolk.org/crashtest"
+DESCRIPTION="Educational car crash simulator"
+HOMEPAGE="http://stolk.org/crashtest/"
SRC_URI="http://stolk.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="x11-libs/fltk
dev-games/ode
media-libs/alsa-lib
+ virtual/opengl
+ virtual/glu
virtual/glut"
DEPEND="${RDEPEND}
>=media-libs/plib-1.8.4"
-S="${WORKDIR}/${P}"/src-${PN}
+S=${WORKDIR}/${P}/src-${PN}
src_unpack() {
unpack ${A}
@@ -30,14 +32,14 @@ src_unpack() {
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
-e "s:<FL/:<fltk-$(fltk-config --api-version)/FL/:" \
- Makefile \
- ${PN}.cxx || die "changing data patch failed"
+ Makefile ${PN}.cxx \
+ || die "sed failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README
- make_desktop_entry ${PN} "Crash Test"
+ make_desktop_entry ${PN} Crashtest
prepgamesdirs
}