summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/nestra/nestra-0.66-r1.ebuild')
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
new file mode 100644
index 000000000000..c7387c1cb97d
--- /dev/null
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.1 2004/03/28 06:19:05 mr_bones_ Exp $
+
+inherit eutils games
+
+PATCH="${P/-/_}-7.diff"
+DESCRIPTION="NES emulation for Linux/x86"
+HOMEPAGE="http://nestra.linuxgames.com/"
+SRC_URI="http://nestra.linuxgames.com/${P}.tar.gz
+ mirror://debian/pool/contrib/n/nestra/${PATCH}.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${WORKDIR}/${PATCH}"
+ sed -i \
+ -e 's:-O2 ::' \
+ -e "s:gcc:gcc ${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin nestra || die "dogamesbin failed"
+ dodoc BUGS CHANGES README
+ doman nestra.6
+ prepgamesdirs
+}