summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/epsxe')
-rw-r--r--games-emulation/epsxe/ChangeLog60
-rw-r--r--games-emulation/epsxe/Manifest6
-rw-r--r--games-emulation/epsxe/epsxe-1.5.2-r1.ebuild44
-rw-r--r--games-emulation/epsxe/epsxe-1.6.0-r3.ebuild44
-rw-r--r--games-emulation/epsxe/files/digest-epsxe-1.5.2-r11
-rw-r--r--games-emulation/epsxe/files/digest-epsxe-1.6.0-r31
-rw-r--r--games-emulation/epsxe/files/epsxe77
7 files changed, 233 insertions, 0 deletions
diff --git a/games-emulation/epsxe/ChangeLog b/games-emulation/epsxe/ChangeLog
new file mode 100644
index 000000000000..8192c6d30eb6
--- /dev/null
+++ b/games-emulation/epsxe/ChangeLog
@@ -0,0 +1,60 @@
+# ChangeLog for app-emulation/epsxe
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/ChangeLog,v 1.1 2003/09/09 16:26:49 vapier Exp $
+
+*epsxe-1.6.0-r3 (24 Aug 2003)
+
+ 24 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a better wrapper script, thanks to Benjamin Hamilton.
+
+*epsxe-1.6.0-r2 (17 Aug 2003)
+
+ 17 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Didnt merge all the changes to epsxe the first time :( #26767.
+
+*epsxe-1.6.0-r1 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add games.eclass support.
+
+*epsxe-1.6.0 (05 Aug 2003)
+
+ 05 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org> epsxe-1.6.0.ebuild:
+ Version bumped. Closes bug #25972. Ebuild by collapse@postmark.net
+
+*epsxe-1.5.2 (27 Jul 2002)
+
+ 17 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add games.eclass support.
+
+ 13 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Updated DEPEND to correctly include gl support #24387.
+
+ 07 Apr 2003; YAMAKURA Makoto <yakina@gentoo.org> files/epsxe:
+ get rid of a possibility of copyright infringement
+
+ 17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> epsxe-1.5.2.ebuild :
+ Added IUSE.
+
+ 06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
+ Added -ppc to keywords
+
+ 27 Jul 2002; Stuart Bouyer <stubear@gentoo.org> epsxe-1.5.2.ebuild :
+
+ Added KEYWORDS="x86" and SLOT for QA requirements.
+
+*epsxe-1.5.2 (3 June 2002)
+
+ 3 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Fixed some incompatibilities with the ebuild
+
+*epsxe-1.5.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-emulation/epsxe/Manifest b/games-emulation/epsxe/Manifest
new file mode 100644
index 000000000000..6a834c5efb61
--- /dev/null
+++ b/games-emulation/epsxe/Manifest
@@ -0,0 +1,6 @@
+MD5 4d0cb4dcc8df6ac525817d8f9d133292 files/epsxe 2119
+MD5 12e7e95d604f2868670e6551ee07053e files/digest-epsxe-1.5.2-r1 60
+MD5 5fe6166fc9d5607a001ee05816ead07e files/digest-epsxe-1.6.0-r3 60
+MD5 a240ad448dc4c030b037a41da55afd16 ChangeLog 2036
+MD5 cb2ae99996d41a556dedc16c7b57525c epsxe-1.5.2-r1.ebuild 1029
+MD5 7005de9e114a2582be0838fabe5bfc15 epsxe-1.6.0-r3.ebuild 1029
diff --git a/games-emulation/epsxe/epsxe-1.5.2-r1.ebuild b/games-emulation/epsxe/epsxe-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2b81b5e04783
--- /dev/null
+++ b/games-emulation/epsxe/epsxe-1.5.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.5.2-r1.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="ePSXe Playstation Emulator"
+HOMEPAGE="http://www.epsxe.com/"
+SRC_URI="http://download.epsxe.com/files/epsxe${PV//.}lin.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="opengl"
+RESTRICT="nostrip" # For some strange reason, strip truncates the whole file
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-libs/glib-1.2
+ =x11-libs/gtk+-1.2*
+ =sys-libs/ncurses-5*
+ =sys-libs/zlib-1*
+ net-misc/wget
+ app-emulation/psemu-peopsspu
+ || (
+ opengl? ( app-emulation/psemu-gpupetemesagl )
+ app-emulation/psemu-peopssoftgpu
+ )"
+
+S=${WORKDIR}
+
+src_install() {
+ dogamesbin ${FILESDIR}/epsxe
+ exeinto ${GAMES_PREFIX_OPT}/${PN}
+ doexe epsxe
+ insinto ${GAMES_PREFIX_OPT}/${PN}
+ doins keycodes.lst
+
+ insinto ${GAMES_LIBDIR}/psemu/cheats
+ doins cheats/*
+
+ dodoc docs/*
+
+ prepgamesdirs
+}
diff --git a/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild b/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
new file mode 100644
index 000000000000..6c887bd9edc2
--- /dev/null
+++ b/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="ePSXe Playstation Emulator"
+HOMEPAGE="http://www.epsxe.com/"
+SRC_URI="http://download.epsxe.com/files/epsxe${PV//.}lin.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="opengl"
+RESTRICT="nostrip" # For some strange reason, strip truncates the whole file
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-libs/glib-1.2
+ =x11-libs/gtk+-1.2*
+ =sys-libs/ncurses-5*
+ =sys-libs/zlib-1*
+ net-misc/wget
+ app-emulation/psemu-peopsspu
+ || (
+ opengl? ( app-emulation/psemu-gpupetemesagl )
+ app-emulation/psemu-peopssoftgpu
+ )"
+
+S=${WORKDIR}
+
+src_install() {
+ dogamesbin ${FILESDIR}/epsxe
+ exeinto ${GAMES_PREFIX_OPT}/${PN}
+ doexe epsxe
+ insinto ${GAMES_PREFIX_OPT}/${PN}
+ doins keycodes.lst
+
+ insinto ${GAMES_LIBDIR}/psemu/cheats
+ doins cheats/*
+
+ dodoc docs/*
+
+ prepgamesdirs
+}
diff --git a/games-emulation/epsxe/files/digest-epsxe-1.5.2-r1 b/games-emulation/epsxe/files/digest-epsxe-1.5.2-r1
new file mode 100644
index 000000000000..cc22445f82b5
--- /dev/null
+++ b/games-emulation/epsxe/files/digest-epsxe-1.5.2-r1
@@ -0,0 +1 @@
+MD5 5834f34cb904b08d95abda057eff3981 epsxe152lin.zip 166559
diff --git a/games-emulation/epsxe/files/digest-epsxe-1.6.0-r3 b/games-emulation/epsxe/files/digest-epsxe-1.6.0-r3
new file mode 100644
index 000000000000..a429bbfa02fe
--- /dev/null
+++ b/games-emulation/epsxe/files/digest-epsxe-1.6.0-r3
@@ -0,0 +1 @@
+MD5 32704cfc77939b9a1bd047f22b70eca2 epsxe160lin.zip 180407
diff --git a/games-emulation/epsxe/files/epsxe b/games-emulation/epsxe/files/epsxe
new file mode 100644
index 000000000000..186c75683357
--- /dev/null
+++ b/games-emulation/epsxe/files/epsxe
@@ -0,0 +1,77 @@
+#
+# Script for launching epsxe
+# $Header: /usr/games/bin/epsxe, v ?.?? 2003/08/17 21:22:07
+#!/bin/sh
+
+source /sbin/functions.sh
+
+PSEMUDIR=/usr/games/lib/psemu
+EPSXEDIR=/opt/epsxe
+
+mkdir -p ~/.epsxe
+cd ~/.epsxe
+cleanlinks
+mkdir -p memcards bios cfg cheats snap sstates patches plugins
+
+shopt -s nullglob
+
+for f in `find "${EPSXEDIR}" -maxdepth 1 -type f -printf '%f '` ; do
+ [ -e "${f}" ] && continue
+ ln -s "${EPSXEDIR}/${f}" "${f}" >& /dev/null
+done
+
+if [ -d "${PSEMUDIR}" ] ; then
+ if [ -d "${PSEMUDIR}/plugins" ]; then
+ for plugin in `find "${PSEMUDIR}/plugins" -maxdepth 1 -type f -printf '%f '` ; do
+ if [ ! -e "plugins/${plugin}" ]; then
+ einfo "Loading new plugin: ${plugin}"
+ ln -s "${PSEMUDIR}/plugins/${plugin}" "plugins/${plugin}"
+ fi
+ done
+ fi
+
+ if [ -d "${PSEMUDIR}/cfg" ]; then
+ for configlib in `find "${PSEMUDIR}/cfg" -maxdepth 1 -iname '*.cfg' -prune -o -type f -printf '%f '`; do
+ if [ ! -e "cfg/${configlib}" ]; then
+ einfo "Loading config utility: ${configlib}"
+ ln -s "${PSEMUDIR}/cfg/${configlib}" "cfg/${configlib}"
+ fi
+ done
+
+ for config in `find "${PSEMUDIR}/cfg" -maxdepth 1 -iname '*.cfg' -type f -printf '%f '`; do
+ if [ ! -e "cfg/${config}" ]; then
+ einfo "Loading default config: ${config}"
+ cp "${PSEMUDIR}/cfg/${config}" "cfg/${config}"
+ fi
+ done
+ fi
+
+ if [ -d "${PSEMUDIR}/cheats" ]; then
+ for cheat in `find "${PSEMUDIR}/cheats" -maxdepth 1 -type f -printf '%f '`; do
+ if [ ! -e "cheats/${cheat}" ]; then
+ ln -s "${PSEMUDIR}/cheats/${cheat}" "cheats/${cheat}"
+ fi
+ done
+ fi
+
+ if [ -d "${PSEMUDIR}/bios" ]; then
+ for bios in `find "${PSEMUDIR}/bios" -maxdepth 1 -type f -printf '%f '`; do
+ if [ ! -e "bios/${bios}" ] ; then
+ ln -s "${PSEMUDIR}/bios/${bios}" "bios/${bios}"
+ fi
+ done
+ fi
+fi
+
+# check for bios
+if [ -z "`cd bios && ls`" ] ; then
+ # if the bios directory is empty, then ... well ...
+ echo
+ ewarn "*** Put your BIOS file into ~/.epsxe/bios/"
+ ewarn " or ePSXe may not work!"
+ echo
+fi
+
+# execute program (with args)
+export LD_PRELOAD="libpthread.so.0:${LD_PRELOAD}" # fix for Bug #26121
+exec ./epsxe "$@"