summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/blight_input/blight_input-0.0.8.ebuild')
-rw-r--r--games-emulation/blight_input/blight_input-0.0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-emulation/blight_input/blight_input-0.0.8.ebuild b/games-emulation/blight_input/blight_input-0.0.8.ebuild
new file mode 100644
index 000000000000..21adfab17fdd
--- /dev/null
+++ b/games-emulation/blight_input/blight_input-0.0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/blight_input/blight_input-0.0.8.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
+
+inherit games
+
+S=${WORKDIR}
+DESCRIPTION="An input plugin for the mupen64 N64 emulator"
+SRC_URI="http://deltaanime.ath.cx/~blight/n64/blight_input_plugin/${P}.tar.gz"
+HOMEPAGE="http://mupen64.emulation64.com/"
+
+KEYWORDS="-* x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=media-libs/libsdl-1.2.4
+ media-libs/freetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Death to all who distribute their stinking config.cache files!
+ rm -f config.cache
+}
+
+src_install() {
+ make install || die "make install failed"
+ exeinto ${GAMES_LIBDIR}/mupen64/plugins
+ doexe src/blight_input.so || die "doexe failed"
+ dodoc AUTHORS ChangeLog README ToDo || die "dodoc failed"
+}