summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/email-py21/email-py21-2.5.ebuild8
-rw-r--r--dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild30
-rw-r--r--dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild17
-rw-r--r--dev-python/pylibpcap/pylibpcap-0.4.ebuild11
-rw-r--r--dev-python/pythoncard/pythoncard-0.6.9.ebuild16
-rw-r--r--dev-python/pythoncard/pythoncard-0.7.ebuild11
-rw-r--r--dev-python/rlcompleter2/rlcompleter2-0.95.ebuild15
-rw-r--r--dev-python/twisted-cvs/twisted-cvs-20021104.ebuild65
-rw-r--r--dev-python/twisted/twisted-1.0.6.ebuild20
9 files changed, 92 insertions, 101 deletions
diff --git a/dev-python/email-py21/email-py21-2.5.ebuild b/dev-python/email-py21/email-py21-2.5.ebuild
index e668da7ad321..1ea250f18ca2 100644
--- a/dev-python/email-py21/email-py21-2.5.ebuild
+++ b/dev-python/email-py21/email-py21-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/email-py21/email-py21-2.5.ebuild,v 1.4 2003/06/23 02:40:38 kutsuya Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/email-py21/email-py21-2.5.ebuild,v 1.5 2003/08/07 03:05:04 vapier Exp $
# Python 2.2.2 and 2.3 come with email version 2, while earlier versions of
# Python 2.2.x come with email version 1. Python 2.1.x and earlier do not come
@@ -15,7 +15,7 @@ S=${WORKDIR}/${P_NEW}
DESCRIPTION="Helps to create, parse, generate, and modify email messages."
HOMEPAGE="http://mimelib.sourceforge.net/"
SRC_URI="mirror://sourceforge/mimelib/${P_NEW}.tar.gz"
+
+LICENSE="PSF-2.2"
SLOT="0"
KEYWORDS="x86 ppc"
-LICENSE="PSF-2.2"
-IUSE=""
diff --git a/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild b/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild
index 7f6887060a41..d374f9812591 100644
--- a/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild
+++ b/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild,v 1.5 2003/06/26 17:03:27 kutsuya Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python-py21/mysql-python-py21-0.9.2-r1.ebuild,v 1.6 2003/08/07 03:04:46 vapier Exp $
+
PYTHON_SLOT_VERSION="2.1"
inherit distutils
+
S="${WORKDIR}/MySQL-python-${PV}"
DESCRIPTION="MySQL Module for python"
-SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/mysql-python/"
+SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-DEPEND="virtual/glibc
- >=dev-db/mysql-3.22.19
- ${DEPEND}"
-RDEPEND="${DEPEND}${RDEPEND}"
KEYWORDS="x86 ppc"
-IUSE=""
-src_compile()
-{
- if has_version '>=dev-db/mysql-4.0.10' >& /dev/null ; then
+DEPEND="virtual/glibc
+ >=dev-db/mysql-3.22.19"
+
+src_compile() {
+ if has_version '>=dev-db/mysql-4.0.10' >& /dev/null ; then
mv setup.py setup.orig
sed -e 's/thread_safe_library = YES/thread_safe_library = NO/' \
setup.orig > setup.py
- fi
- distutils_src_compile
+ fi
+ distutils_src_compile
}
-src_install()
-{
+src_install() {
distutils_src_install
dohtml doc/*
}
-
diff --git a/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild b/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild
index 240296f2f739..9b475be0a38c 100644
--- a/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild
+++ b/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild,v 1.4 2003/06/26 17:03:27 kutsuya Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mysql-python-py21/mysql-python-py21-0.9.2.ebuild,v 1.5 2003/08/07 03:04:46 vapier Exp $
PYTHON_SLOT_VERSION="2.1"
+
inherit distutils
S="${WORKDIR}/MySQL-python-${PV}"
DESCRIPTION="MySQL Module for python"
-SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/mysql-python/"
+SRC_URI="mirror://sourceforge/mysql-python/MySQL-python-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-DEPEND="virtual/glibc
- >=dev-db/mysql-3.22.19
- ${DEPEND}"
-RDEPEND="${DEPEND}${RDEPEND}"
KEYWORDS="x86 ppc"
-IUSE=""
+
+DEPEND="virtual/glibc
+ >=dev-db/mysql-3.22.19"
src_install() {
distutils_src_install
dohtml doc/*
}
-
diff --git a/dev-python/pylibpcap/pylibpcap-0.4.ebuild b/dev-python/pylibpcap/pylibpcap-0.4.ebuild
index b1feda087799..2bbe77d40569 100644
--- a/dev-python/pylibpcap/pylibpcap-0.4.ebuild
+++ b/dev-python/pylibpcap/pylibpcap-0.4.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/pylibpcap-0.4.ebuild,v 1.4 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibpcap/pylibpcap-0.4.ebuild,v 1.5 2003/08/07 03:05:20 vapier Exp $
inherit distutils
-S=${WORKDIR}/${P}
DESCRIPTION="Python interface to libpcap"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/${PN}/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-IUSE=""
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
@@ -21,5 +19,4 @@ src_install() {
distutils_src_install
insinto /usr/share/doc/${PF}/examples
doins examples/*
-}
-
+}
diff --git a/dev-python/pythoncard/pythoncard-0.6.9.ebuild b/dev-python/pythoncard/pythoncard-0.6.9.ebuild
index e3c689e04e6c..485459de77af 100644
--- a/dev-python/pythoncard/pythoncard-0.6.9.ebuild
+++ b/dev-python/pythoncard/pythoncard-0.6.9.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.6.9.ebuild,v 1.5 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.6.9.ebuild,v 1.6 2003/08/07 03:01:31 vapier Exp $
DESCRIPTION="Cross-platform GUI construction kit for python"
-SRC_URI="mirror://sourceforge/pythoncard/PythonCardPrototype-${PV}.tar.gz"
HOMEPAGE="http://pythoncard.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/pythoncard/PythonCardPrototype-${PV}.tar.gz"
+
LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="x86"
DEPEND="virtual/python
>=dev-python/wxPython-2.3.2.1-r2"
-SLOT="0"
-KEYWORDS="x86"
+
S=${WORKDIR}/PythonCardPrototype-${PV}
src_compile() {
@@ -21,7 +23,3 @@ src_install() {
python setup.py install --prefix=${D}/usr || die "Install Failed"
dodoc README.txt README_StyleEditor.txt
}
-
-
-
-
diff --git a/dev-python/pythoncard/pythoncard-0.7.ebuild b/dev-python/pythoncard/pythoncard-0.7.ebuild
index 81ce07982752..6dd3b40fe3c1 100644
--- a/dev-python/pythoncard/pythoncard-0.7.ebuild
+++ b/dev-python/pythoncard/pythoncard-0.7.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.7.ebuild,v 1.4 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythoncard/pythoncard-0.7.ebuild,v 1.5 2003/08/07 03:01:31 vapier Exp $
inherit distutils
DESCRIPTION="Cross-platform GUI construction kit for python"
-SRC_URI="mirror://sourceforge/pythoncard/PythonCardPrototype-${PV}.tar.gz"
HOMEPAGE="http://pythoncard.sourceforge.net/index.html"
-LICENSE="PYTHON"
+SRC_URI="mirror://sourceforge/pythoncard/PythonCardPrototype-${PV}.tar.gz"
-DEPEND=">=dev-python/wxPython-2.3.2.1-r2"
+LICENSE="PYTHON"
SLOT="0"
KEYWORDS="x86 ~sparc"
+DEPEND=">=dev-python/wxPython-2.3.2.1-r2"
+
S=${WORKDIR}/PythonCardPrototype-${PV}
mydoc="README.txt README_StyleEditor.txt"
diff --git a/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild b/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild
index 7fcaa1cc4a19..b3fb305f8743 100644
--- a/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild
+++ b/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild
@@ -1,21 +1,20 @@
# Copyright 2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild,v 1.5 2003/07/12 12:49:26 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rlcompleter2/rlcompleter2-0.95.ebuild,v 1.6 2003/08/07 03:06:14 vapier Exp $
inherit distutils
DESCRIPTION="Python command line completion."
HOMEPAGE="http://codespeak.net/rlcompleter2/"
-SRC_URI="${HOMEPAGE}download/${P}.tar.gz"
+SRC_URI="http://codespeak.net/rlcompleter2/download/${P}.tar.gz"
+
+LICENSE="PSF-2.2"
SLOT="0"
KEYWORDS="x86 ~ppc"
-LICENSE="PSF-2.2"
-IUSE=""
-mydoc="PKG-INFO ${mydoc}"
+DOCS="PKG-INFO"
-pkg_postinst()
-{
+pkg_postinst() {
ewarn "Please read the README, and follow instructions in order to"
ewarn "execute and configure rlcompleter2."
}
diff --git a/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild b/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
index 28ed03232c31..4eaccdb012a8 100644
--- a/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
+++ b/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild,v 1.5 2003/06/22 12:16:00 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-cvs/twisted-cvs-20021104.ebuild,v 1.6 2003/08/07 03:03:13 vapier Exp $
ECVS_USER="anon"
ECVS_SERVER="twistedmatrix.com:/cvs"
@@ -8,51 +8,50 @@ ECVS_MODULE="Twisted"
ECVS_CVS_OPTIONS="-dP"
inherit cvs
+inherit distutils
S=${WORKDIR}/${ECVS_MODULE}
DESCRIPTION="Twisted is a framework, written in Python, for writing networked applications."
-SRC_URI=""
HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI=""
+
LICENSE="LGPL-2.1"
SLOT="0"
-RDEPEND="virtual/python"
-DEPEND="$DEPEND
- >=dev-python/epydoc-1.1
- >=dev-python/pycrypto-1.9_alpha4"
KEYWORDS="~x86 ~alpha"
-IUSE=""
-inherit distutils
+RDEPEND="virtual/python"
+DEPEND="${DEPEND}
+ >=dev-python/epydoc-1.1
+ >=dev-python/pycrypto-1.9_alpha4"
src_compile() {
- distutils_src_compile
- ## .ps & pdf generation (book) sandbox violation ..
- ##${S}/admin/process-docs
- # from admin/release-twisted
-# cd ${S}
-# epydoc -o doc/api twisted/* &&
-# cp doc/api/index.html doc/api/index.html.bak &&
-# cp doc/api/epydoc-index.html doc/api/index.html
-# tree doc/api
+ distutils_src_compile
+ ## .ps & pdf generation (book) sandbox violation ..
+ ##${S}/admin/process-docs
+ # from admin/release-twisted
+ #cd ${S}
+ #epydoc -o doc/api twisted/* &&
+ #cp doc/api/index.html doc/api/index.html.bak &&
+ #cp doc/api/epydoc-index.html doc/api/index.html
+ #tree doc/api
}
src_install() {
- distutils_src_install
-
- # next few lines will install docs: 9.4 megs!
- dodir /usr/share/doc/${PF}
- # of course it's documentation!
- doman doc/man/*.[0-9n]
- rm -rf doc/man # don't dupe the man pages
- cd doc
- cp -r . ${D}/usr/share/doc/${PF}
- cd ../
-
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
}
pkg_postinst() {
- echo
- einfo "This is for testing only! Do not submit bugs regarding this to"
- einfo "Bugzilla. Instead mail me at lordvan@gentoo.org"
- echo
+ echo
+ einfo "This is for testing only! Do not submit bugs regarding this to"
+ einfo "Bugzilla. Instead mail me at lordvan@gentoo.org"
+ echo
}
diff --git a/dev-python/twisted/twisted-1.0.6.ebuild b/dev-python/twisted/twisted-1.0.6.ebuild
index c97d05485d45..c017af1b5544 100644
--- a/dev-python/twisted/twisted-1.0.6.ebuild
+++ b/dev-python/twisted/twisted-1.0.6.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.6.ebuild,v 1.2 2003/07/02 20:47:33 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.6.ebuild,v 1.3 2003/08/07 03:02:12 vapier Exp $
-IUSE="gtk2 doc"
+inherit distutils
-S=${WORKDIR}/Twisted-${PV}
-DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
-SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 alpha sparc"
+IUSE="gtk2 doc"
+
DEPEND=">=dev-lang/python-2.2*
>=dev-python/pycrypto-1.9_alpha4
gtk? ( =dev-python/pygtk-0.6* )
gtk2? ( >=dev-python/pygtk-1.99* )"
-KEYWORDS="x86 alpha sparc"
-inherit distutils
+S=${WORKDIR}/Twisted-${PV}
src_install() {
distutils_src_install
@@ -38,6 +40,4 @@ src_install() {
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
fi
-
}
-