summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-conch/twisted-conch-8.2.0.ebuild')
-rw-r--r--dev-python/twisted-conch/twisted-conch-8.2.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild b/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild
index 7119e8fb3489..8362fa57c615 100644
--- a/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild,v 1.3 2009/09/06 21:02:31 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-8.2.0.ebuild,v 1.4 2009/10/30 12:30:01 arfrever Exp $
-MY_PACKAGE=Conch
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+MY_PACKAGE="Conch"
-inherit twisted eutils versionator
+inherit twisted versionator
-DESCRIPTION="Twisted SSHv2 implementation."
+DESCRIPTION="Twisted SSHv2 implementation"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
>=dev-python/pycrypto-1.9_alpha6"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
-IUSE=""
+PYTHON_MODNAME="twisted/conch twisted/plugins"