summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch')
-rw-r--r--dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch b/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch
new file mode 100644
index 000000000000..be31eebb64b2
--- /dev/null
+++ b/dev-python/pythonmagick/files/pythonmagick-0.8-python26.patch
@@ -0,0 +1,31 @@
+diff -Nur PythonMagick-0.8.orig/configure.ac PythonMagick-0.8/configure.ac
+--- PythonMagick-0.8.orig/configure.ac 2009-02-02 11:53:17.965859950 +0000
++++ PythonMagick-0.8/configure.ac 2009-02-02 11:54:04.118583794 +0000
+@@ -17,7 +17,7 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ AC_PROG_LIBTOOL
+-AM_PATH_PYTHON(2.5)
++AM_PATH_PYTHON
+ PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+diff -Nur PythonMagick-0.8.orig/m4/ax_python.m4 PythonMagick-0.8/m4/ax_python.m4
+--- PythonMagick-0.8.orig/m4/ax_python.m4 2009-02-02 11:53:17.965859950 +0000
++++ PythonMagick-0.8/m4/ax_python.m4 2009-02-02 11:53:50.063895989 +0000
+@@ -58,13 +58,13 @@
+ AC_DEFUN([AX_PYTHON],
+ [AC_MSG_CHECKING(for python build information)
+ AC_MSG_RESULT([])
+-for python in python2.5 python2.4 python2.3 python2.2 python2.1 python; do
++for python in python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
+ AC_CHECK_PROGS(PYTHON_BIN, [$python])
+ ax_python_bin=$PYTHON_BIN
+ if test x$ax_python_bin != x; then
+ AC_CHECK_LIB($ax_python_bin, main, ax_python_lib=$ax_python_bin, ax_python_lib=no)
+ AC_CHECK_HEADER([$ax_python_bin/Python.h],
+- [[ax_python_header=`locate $ax_python_bin/Python.h | sed -e s,/Python.h,,`]],
++ [[ax_python_header=`locate $ax_python_bin/Python.h | head -n 1 | sed -e s,/Python.h,,`]],
+ ax_python_header=no)
+ if test $ax_python_lib != no; then
+ if test $ax_python_header != no; then