summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pystache/pystache-0.5.3.ebuild')
-rw-r--r--dev-python/pystache/pystache-0.5.3.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/pystache/pystache-0.5.3.ebuild b/dev-python/pystache/pystache-0.5.3.ebuild
index ac2578d18bd6..b8eb6b2fbe3d 100644
--- a/dev-python/pystache/pystache-0.5.3.ebuild
+++ b/dev-python/pystache/pystache-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pystache/pystache-0.5.3.ebuild,v 1.1 2014/02/06 16:58:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pystache/pystache-0.5.3.ebuild,v 1.2 2014/02/06 17:08:15 bicatali Exp $
EAPI=5
@@ -14,8 +14,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib
+ nosetests || die
+}