summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyfits/pyfits-2.3.1.ebuild')
-rw-r--r--dev-python/pyfits/pyfits-2.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyfits/pyfits-2.3.1.ebuild b/dev-python/pyfits/pyfits-2.3.1.ebuild
new file mode 100644
index 000000000000..a9727f010465
--- /dev/null
+++ b/dev-python/pyfits/pyfits-2.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/pyfits-2.3.1.ebuild,v 1.1 2010/06/03 19:48:01 bicatali Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Provides an interface to FITS formatted files under python"
+SRC_URI="http://www.stsci.edu/resources/software_hardware/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/pyfits"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+LICENSE="BSD"
+
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ local t
+ for t in lib/tests/testPyfits*.py; do
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" "${t}" || die "${t} failed with Python ${PYTHON_ABI}"
+ done
+ }
+ python_execute_function testing
+}