summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/psycopg/psycopg-2.3.2.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.3.2.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/psycopg/psycopg-2.3.2.ebuild b/dev-python/psycopg/psycopg-2.3.2.ebuild
deleted file mode 100644
index b639a1a16fe6..000000000000
--- a/dev-python/psycopg/psycopg-2.3.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.3.2.ebuild,v 1.5 2011/02/08 22:31:31 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils eutils
-
-MY_P="${PN}2-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
-SRC_URI="http://initd.org/pub/software/psycopg/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc examples mxdatetime"
-
-DEPEND=">=dev-db/postgresql-base-8.1
- mxdatetime? ( dev-python/egenix-mx-base )"
-RDEPEND="${DEPEND}"
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="AUTHORS doc/HACKING doc/psycopg2.txt doc/SUCCESS"
-PYTHON_MODNAME="${PN}2"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
- epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
- fi
-
- if use mxdatetime; then
- sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc/html > /dev/null
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}