summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/psycopg/psycopg-2.0.9.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.0.9.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/psycopg/psycopg-2.0.9.ebuild b/dev-python/psycopg/psycopg-2.0.9.ebuild
deleted file mode 100644
index e81895a8b8dc..000000000000
--- a/dev-python/psycopg/psycopg-2.0.9.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.0.9.ebuild,v 1.1 2009/03/29 17:32:00 chutzpah Exp $
-
-NEED_PYTHON=2.4
-
-inherit eutils distutils
-
-MY_P=${PN}2-${PV}
-
-DESCRIPTION="PostgreSQL database adapter for Python."
-SRC_URI="http://initd.org/pub/software/psycopg/${MY_P}.tar.gz"
-HOMEPAGE="http://initd.org/projects/psycopg2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-LICENSE="GPL-2"
-IUSE="debug doc examples mxdatetime"
-
-DEPEND="virtual/postgresql-base
- mxdatetime? ( dev-python/egenix-mx-base )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PYTHON_MODNAME=${PN}2
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
- fi
-
- if use mxdatetime; then
- sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
- fi
-}
-
-src_install() {
- DOCS="AUTHORS doc/HACKING doc/SUCCESS doc/TODO doc/async.txt"
- distutils_src_install
-
- insinto /usr/share/doc/${PF}
- use examples && doins -r examples
-
- cd doc
- use doc && dohtml -r .
-}