summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python/dbus-python-0.83.0.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/dbus-python/dbus-python-0.83.0.ebuild b/dev-python/dbus-python/dbus-python-0.83.0.ebuild
deleted file mode 100644
index fd0b03d99d93..000000000000
--- a/dev-python/dbus-python/dbus-python-0.83.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0.ebuild,v 1.2 2009/01/18 18:59:43 eva Exp $
-
-inherit python multilib
-
-DESCRIPTION="Python bindings for the D-Bus messagebus."
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings \
-http://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="test"
-
-RDEPEND=">=dev-lang/python-2.4.4-r5
- >=dev-python/pyrex-0.9.3-r2
- >=dev-libs/dbus-glib-0.71
- >=sys-apps/dbus-1.0.0"
-
-DEPEND="${RDEPEND}
- test? ( dev-python/pygobject )
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-}
-
-src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV}
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-}
-
-pkg_postinst() {
- python_version
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}