summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/ZendFramework/ChangeLog7
-rw-r--r--dev-php5/ZendFramework/ZendFramework-1.7.7.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-php5/ZendFramework/ChangeLog b/dev-php5/ZendFramework/ChangeLog
index 1b19a1e1ba58..f7c36234b2f4 100644
--- a/dev-php5/ZendFramework/ChangeLog
+++ b/dev-php5/ZendFramework/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/ZendFramework
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.52 2009/03/07 11:47:31 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ChangeLog,v 1.53 2009/03/29 08:52:04 pva Exp $
+
+*ZendFramework-1.7.7 (29 Mar 2009)
+
+ 29 Mar 2009; Peter Volkov <pva@gentoo.org> +ZendFramework-1.7.7.ebuild:
+ Version bump.
*ZendFramework-1.7.6 (07 Mar 2009)
diff --git a/dev-php5/ZendFramework/ZendFramework-1.7.7.ebuild b/dev-php5/ZendFramework/ZendFramework-1.7.7.ebuild
new file mode 100644
index 000000000000..2641803bc75a
--- /dev/null
+++ b/dev-php5/ZendFramework/ZendFramework-1.7.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/ZendFramework/ZendFramework-1.7.7.ebuild,v 1.1 2009/03/29 08:52:04 pva Exp $
+
+PHP_LIB_NAME="Zend"
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="Zend Framework is a high quality and open source framework for developing Web Applications."
+HOMEPAGE="http://framework.zend.com/"
+SRC_URI="!minimal? ( http://framework.zend.com/releases/${P}/${P}.tar.gz )
+ minimal? ( http://framework.zend.com/releases/${P}/${P}-minimal.tar.gz )
+ doc? (
+ http://framework.zend.com/releases/${P}/${P}-apidoc.tar.gz
+ http://framework.zend.com/releases/${P}/${P}-manual-en.tar.gz )"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples minimal"
+
+DEPEND=""
+RDEPEND=""
+need_php_by_category
+
+src_unpack() {
+ if use minimal ; then
+ S="${WORKDIR}/${P}-minimal"
+ fi
+
+ unpack ${A}
+
+ cd "${S}"
+}
+
+src_install() {
+ php-lib-r1_src_install library/Zend $(cd library/Zend ; find . -type f -print)
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+
+ if ! use minimal ; then
+ doins -r demos
+ fi
+ fi
+
+ dodoc README.txt
+ if use doc ; then
+ dohtml -r documentation/*
+ fi
+}
+
+pkg_postinst() {
+ elog "For more info, please take a look at the manual at:"
+ elog "http://framework.zend.com/manual"
+ elog ""
+
+ if use minimal; then
+ elog "You have installed the minimal version of ZendFramework,"
+ elog "so the Dojo toolkit, demos and tests have not been installed."
+ else
+ elog "You have installed the full version of ZendFramework, which"
+ elog "includes the Dojo toolkit, demos and tests."
+ elog "To install ZendFramework without there, enable the"
+ elog "minimal USE flag."
+ fi
+}