summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild')
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild
new file mode 100644
index 000000000000..836e97ec24dc
--- /dev/null
+++ b/dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ppcre/cl-ppcre-0.7.0.ebuild,v 1.1 2003/10/23 18:28:54 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="mirror://gentoo/${PN}_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-ppcre
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG README doc/benchmarks.2002-12-22.txt
+ dohtml doc/index.html
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}