summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jemalloc/jemalloc-3.6.0.ebuild')
-rw-r--r--dev-libs/jemalloc/jemalloc-3.6.0.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-libs/jemalloc/jemalloc-3.6.0.ebuild b/dev-libs/jemalloc/jemalloc-3.6.0.ebuild
index 4e730c7f7224..f913c86508dc 100644
--- a/dev-libs/jemalloc/jemalloc-3.6.0.ebuild
+++ b/dev-libs/jemalloc/jemalloc-3.6.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-3.6.0.ebuild,v 1.11 2014/12/28 11:56:01 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-3.6.0.ebuild,v 1.12 2015/07/20 06:30:03 vapier Exp $
EAPI=5
-inherit autotools-multilib eutils flag-o-matic
+inherit autotools-multilib eutils flag-o-matic toolchain-funcs
DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
HOMEPAGE="http://www.canonware.com/jemalloc/"
@@ -12,14 +12,18 @@ SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="debug static-libs stats"
+
HTML_DOCS=( doc/jemalloc.html )
+
PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
"${FILESDIR}/${PN}-3.5.1-no-pprof.patch"
"${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
)
+
MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+
# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
# but jemalloc doesn't implement them in its configure; need this here to
# supress the warnings until automagic is removed from the eclass
@@ -30,6 +34,10 @@ src_configure() {
$(use_enable stats)
)
use sparc && append-cppflags -DLG_QUANTUM=4 -mcpu=ultrasparc
+ # The configure test for page shift requires running code which fails
+ # when cross-compiling. Since it uses _SC_PAGESIZE, and the majority
+ # of systems use 4096 as the base page size, just hardcode 12 here.
+ tc-is-cross-compiler && export je_cv_static_page_shift=12
autotools-multilib_src_configure
}