summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/yasm/yasm-0.6.2.ebuild')
-rw-r--r--dev-lang/yasm/yasm-0.6.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/yasm/yasm-0.6.2.ebuild b/dev-lang/yasm/yasm-0.6.2.ebuild
new file mode 100644
index 000000000000..359ae421fd76
--- /dev/null
+++ b/dev-lang/yasm/yasm-0.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.6.2.ebuild,v 1.1 2007/09/22 00:41:55 vapier Exp $
+
+DESCRIPTION="assembler that supports amd64"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Remove macho tests (gas{32,64},nasm{32,64}) until fixed upstream.
+ # Necessary to pass test phase on at least amd64 with gcc-4.1.2.
+ sed -i \
+ -e '/modules\/objfmts\/macho\/tests\/.*\/.*macho.*_test.sh/d' \
+ Makefile.in
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS INSTALL
+}