summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/constantine/constantine-0.5.ebuild')
-rw-r--r--dev-java/constantine/constantine-0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/constantine/constantine-0.5.ebuild b/dev-java/constantine/constantine-0.5.ebuild
new file mode 100644
index 000000000000..a89eda93aae9
--- /dev/null
+++ b/dev-java/constantine/constantine-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/constantine/constantine-0.5.ebuild,v 1.1 2009/05/23 07:38:01 caster Exp $
+
+JAVA_PKG_IUSE="source test"
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides Java values for common platform C constants"
+HOMEPAGE="http://kenai.com/projects/constantine"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit4 )"
+
+src_compile() {
+ # ecj doesn't like some cast for some reason
+ java-pkg_force-compiler javac
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use source && java-pkg_dosrc src/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test -Dlibs.junit_4.classpath="$(java-pkg_getjars --with-dependencies junit-4)"
+}