summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x11/x11-1.4.6.1.ebuild')
-rw-r--r--dev-haskell/x11/x11-1.4.6.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-haskell/x11/x11-1.4.6.1.ebuild b/dev-haskell/x11/x11-1.4.6.1.ebuild
index b5e48883a1c9..c7f07425f2e4 100644
--- a/dev-haskell/x11/x11-1.4.6.1.ebuild
+++ b/dev-haskell/x11/x11-1.4.6.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.6.1.ebuild,v 1.1 2009/10/26 22:19:50 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.4.6.1.ebuild,v 1.2 2009/10/26 22:56:59 kolmodin Exp $
-CABAL_FEATURES="lib profile haddock hscolour"
-inherit haskell-cabal
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal eutils
MY_PN="X11"
MY_P="${MY_PN}-${PV}"
@@ -17,11 +17,11 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~sparc ~x86"
IUSE="xinerama"
-DEPEND=">=dev-haskell/cabal-1.2"
-RDEPEND="${DEPEND}
- >=dev-lang/ghc-6.8
+RDEPEND=">=dev-lang/ghc-6.8
x11-libs/libX11
xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
S="${WORKDIR}/${MY_P}"