summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gtk-sharp')
-rw-r--r--dev-dotnet/gtk-sharp/ChangeLog9
-rw-r--r--dev-dotnet/gtk-sharp/Manifest4
-rw-r--r--dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.3.912
-rw-r--r--dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.912
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.3.91.ebuild91
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-2.5.91.ebuild91
6 files changed, 198 insertions, 1 deletions
diff --git a/dev-dotnet/gtk-sharp/ChangeLog b/dev-dotnet/gtk-sharp/ChangeLog
index f9d5fdcaf1d7..c7333d54b266 100644
--- a/dev-dotnet/gtk-sharp/ChangeLog
+++ b/dev-dotnet/gtk-sharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/gtk-sharp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.44 2005/08/17 00:40:05 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.45 2005/09/16 06:48:16 latexer Exp $
+
+*gtk-sharp-2.5.91 (16 Sep 2005)
+*gtk-sharp-2.3.91 (16 Sep 2005)
+
+ 16 Sep 2005; Peter Johanson <latexer@gentoo.org> +gtk-sharp-2.3.91.ebuild,
+ +gtk-sharp-2.5.91.ebuild:
+ Bump.
*gtk-sharp-2.5.90 (17 Aug 2005)
*gtk-sharp-2.3.90 (17 Aug 2005)
diff --git a/dev-dotnet/gtk-sharp/Manifest b/dev-dotnet/gtk-sharp/Manifest
index 10c41994f50f..a9deb8652d8d 100644
--- a/dev-dotnet/gtk-sharp/Manifest
+++ b/dev-dotnet/gtk-sharp/Manifest
@@ -1,10 +1,14 @@
+MD5 a530fa1805bc5f3937ffb635c4671330 gtk-sharp-2.3.91.ebuild 2284
MD5 298854cb874563b38d41e775bb3b27be gtk-sharp-1.0.8.ebuild 1462
MD5 9a093277e314eea51d71e18007ff6455 ChangeLog 11927
MD5 e06909c47712ae995f4879eefb22e38b metadata.xml 160
MD5 9968e0d9182edd6c6fafd54c48149beb gtk-sharp-1.0.10.ebuild 1589
+MD5 b059a7cd959ad35a0d6c9a68b063cb1f gtk-sharp-2.5.91.ebuild 2284
MD5 6ce9b4d8e9280538abf78f7d16c75580 gtk-sharp-1.0.8-r1.ebuild 1465
MD5 a530fa1805bc5f3937ffb635c4671330 gtk-sharp-2.3.90.ebuild 2284
MD5 b059a7cd959ad35a0d6c9a68b063cb1f gtk-sharp-2.5.90.ebuild 2284
+MD5 3ddf35279f4dcf4483ddda4c44e601d6 files/digest-gtk-sharp-2.3.91 149
+MD5 e183a3b0925a371bebfb8e0eab284191 files/digest-gtk-sharp-2.5.91 149
MD5 fef3bd202b3f48969673897302f3be4c files/digest-gtk-sharp-1.0.8 147
MD5 fef3bd202b3f48969673897302f3be4c files/digest-gtk-sharp-1.0.8-r1 147
MD5 302dbc192d1c69a0ba956625d73ef2c2 files/digest-gtk-sharp-1.0.10 149
diff --git a/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.3.91 b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.3.91
new file mode 100644
index 000000000000..5c3f93b55b85
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.3.91
@@ -0,0 +1,2 @@
+MD5 d8c8ba0679a2fbb4dcfebe50c3d43540 gtk-sharp-2.3.91.tar.gz 2116967
+MD5 5d53f843ba6b711fafcb87581318416c gtk-sharp-2.3.91-configurable.diff.gz 1346
diff --git a/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.91 b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.91
new file mode 100644
index 000000000000..151b0d2727c0
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-2.5.91
@@ -0,0 +1,2 @@
+MD5 fc1ac020b2a9d9ff0fbfa4c00ffdb20c gtk-sharp-2.5.91.tar.gz 2126195
+MD5 2f84cde83d416fb5aecadf8e8cf87b83 gtk-sharp-2.5.91-configurable.diff.gz 1349
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.3.91.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.3.91.ebuild
new file mode 100644
index 000000000000..1a44c3ad1383
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.3.91.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-2.3.91.ebuild,v 1.1 2005/09/16 06:48:16 latexer Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="http://go-mono.com/sources/${PN}-2.0/${P}.tar.gz
+ mirror://gentoo/${P}-configurable.diff.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND=">=sys-apps/sed-4.0
+ >=dev-lang/mono-1.0
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/orbit-2.8.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${WORKDIR}/${P}-configurable.diff
+ #fixes support with pkgconfig-0.17, bug #92503
+ sed -i -e 's/\<PKG_PATH\>/GTK_SHARP_PKG_PATH/g' configure.in
+
+ # Use correct libdir in pkgconfig files
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/*/{,GConf}/*.pc.in || die
+
+ export WANT_AUTOMAKE="1.8"
+ aclocal || die
+ automake || die
+ autoconf || die
+ libtoolize --copy --force
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+
+ local myconf=""
+ # These are the same as from gtk-sharp-component.eclass
+ for package in art glade gnome gnomevfs gtkhtml rsvg vte
+ do
+ myconf="${myconf} --disable-${package}"
+ done
+
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+
+ #if use doc && has_version dev-util/monodoc
+ #then
+ # cd ${S}/doc
+ # emake -j1 assemble || die "Failed to generate docs"
+ #fi
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}-2.0" \
+ DESTDIR=${D} install || die
+
+ dodoc README* ChangeLog
+
+ #if use doc && has_version dev-util/monodoc
+ #then
+ # cd ${S}/doc
+ # insinto $(monodoc --get-sourcesdir)
+ # doins gtk-sharp-docs.{tree,zip}
+ #fi
+}
+
+pkg_postinst() {
+ if use doc && ! has_version dev-util/monodoc
+ then
+ ewarn
+ ewarn "Although 'doc' is in the USE flag list, gtk-sharp will"
+ ewarn "not install its monodoc documentation unless you have monodoc"
+ ewarn "installed. If you want the documentation to be available in"
+ ewarn "monodoc, please emerge monodoc then re-emerge gtk-sharp."
+ fi
+}
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-2.5.91.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-2.5.91.ebuild
new file mode 100644
index 000000000000..aeda72d56ca3
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-2.5.91.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-2.5.91.ebuild,v 1.1 2005/09/16 06:48:16 latexer Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="http://go-mono.com/sources/${PN}-2.0/${P}.tar.gz
+ mirror://gentoo/${P}-configurable.diff.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND=">=sys-apps/sed-4.0
+ >=dev-lang/mono-1.0
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/orbit-2.8.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${WORKDIR}/${P}-configurable.diff
+ #fixes support with pkgconfig-0.17, bug #92503
+ sed -i -e 's/\<PKG_PATH\>/GTK_SHARP_PKG_PATH/g' configure.in
+
+ # Use correct libdir in pkgconfig files
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/*/{,GConf}/*.pc.in || die
+
+ export WANT_AUTOMAKE="1.8"
+ aclocal || die
+ automake || die
+ autoconf || die
+ libtoolize --copy --force
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+
+ local myconf=""
+ # These are the same as from gtk-sharp-component.eclass
+ for package in art glade gnome gnomevfs gtkhtml rsvg vte
+ do
+ myconf="${myconf} --disable-${package}"
+ done
+
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+
+ #if use doc && has_version dev-util/monodoc
+ #then
+ # cd ${S}/doc
+ # emake -j1 assemble || die "Failed to generate docs"
+ #fi
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}-2.0" \
+ DESTDIR=${D} install || die
+
+ dodoc README* ChangeLog
+
+ #if use doc && has_version dev-util/monodoc
+ #then
+ # cd ${S}/doc
+ # insinto $(monodoc --get-sourcesdir)
+ # doins gtk-sharp-docs.{tree,zip}
+ #fi
+}
+
+pkg_postinst() {
+ if use doc && ! has_version dev-util/monodoc
+ then
+ ewarn
+ ewarn "Although 'doc' is in the USE flag list, gtk-sharp will"
+ ewarn "not install its monodoc documentation unless you have monodoc"
+ ewarn "installed. If you want the documentation to be available in"
+ ewarn "monodoc, please emerge monodoc then re-emerge gtk-sharp."
+ fi
+}